summaryrefslogtreecommitdiff
path: root/sysutils/portupgrade-devel/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-08-21 12:29:39 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-08-21 12:29:39 +0000
commit3c299339fed452db52de3d83e80598bccc19893c (patch)
tree53b4f794d6e66e7eb123f24167e8dd9f04733cf7 /sysutils/portupgrade-devel/Makefile
parentAdd the optional WITH_OGGVORBIS variable. It will also be automatically set (diff)
Update to 20010821, with many improvements.
Overall: - Disregard -r and -R when -a is also specified; there is no need to recurse when you do with everything. - Fix a bug in -r and -R routines where it might fail in error if dependencies of a package were all wrong. [Caught by: Mamoru Iwaki <iwaki@bsp.bc.niigata-u.ac.jp>] - Fix the support for the case where PORTSDIR is a symlink. - Squeeze //'s. - Run `stty sane' before building each port, on interrupt, and before exit. - Accept portorigin_glob and pkgname_glob with paths, except for -x/--exclude. portupgrade: - Fix `portupgrade -Ni' (portinstall -i). - Skip ports and packages that once failed, and do not try to upgrade multiple packages of an origin. - If a port or a package failed to build or install, skip its dependents. This behavior can be overridden by the new option, -g/--go-on. pkgdepfix: - Backup +CONTENTS files before removing duplicates. portsclean: - Start implementing -L/--libclean. misc/tcsh/complete.sample: - Add a simple example of tcsh completion definitions. [Contributed by: kuwa@flab.fujitsu.co.jp]
Diffstat (limited to 'sysutils/portupgrade-devel/Makefile')
-rw-r--r--sysutils/portupgrade-devel/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/sysutils/portupgrade-devel/Makefile b/sysutils/portupgrade-devel/Makefile
index 9ad34ed8993d..6342d2dc71b5 100644
--- a/sysutils/portupgrade-devel/Makefile
+++ b/sysutils/portupgrade-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= portupgrade
-PORTVERSION= 20010820
+PORTVERSION= 20010821
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://www.iDaemons.org/distfiles/
@@ -43,6 +43,10 @@ MAN1= pkg_deinstall.1 \
MLINKS= portupgrade.1 portinstall.1
MANCOMPRESSED= yes
+DOCS= ChangeLog README
+
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
+
post-patch:
${RUBY} -i -pe 'sub %r:/usr/local:, "${LOCALBASE}"' ${WRKSRC}/pkgdb.rb
@@ -51,8 +55,12 @@ do-install:
${MKDIR} ${PREFIX}/share/zsh/site-functions
${INSTALL_DATA} ${WRKSRC}/misc/zsh/* ${PREFIX}/share/zsh/site-functions/
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/${PORTNAME}/
+ ${MKDIR} ${EXAMPLESDIR}/tcsh
+ ${INSTALL_DATA} ${WRKSRC}/misc/tcsh/* ${EXAMPLESDIR}/tcsh/
+ ${MKDIR} ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
.endif
.include <bsd.port.mk>