summaryrefslogtreecommitdiff
path: root/sysutils/portupgrade-devel/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-17 23:06:40 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-17 23:06:40 +0000
commit230a5071f6e458ce51c1e8cb86e06788fdd647ff (patch)
treecec3fb75c77cbd8a95d6901f615497d8a699085e /sysutils/portupgrade-devel/Makefile
parentport did not install with NDEBUG=1 (diff)
Add portupgrade, a tool to upgrade installed packages with ports.
It upgrades ports without reinstalling dependent packages by directly modifying the package info recorded in the files under /var/db/pkg. e.g. portupgrade gtk portupgrade -cC gnome\* It currently has many design flaws (to me at least) but I am releasing this because it's functionally stable enough to use. (I believe.. ;) Use with care, at your own risk.
Diffstat (limited to 'sysutils/portupgrade-devel/Makefile')
-rw-r--r--sysutils/portupgrade-devel/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/portupgrade-devel/Makefile b/sysutils/portupgrade-devel/Makefile
new file mode 100644
index 000000000000..4ffbae362aff
--- /dev/null
+++ b/sysutils/portupgrade-devel/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: portupgrade
+# Date created: 18 March 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= portupgrade
+PORTVERSION= 1.14
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= knu
+DISTNAME= pkgtools-20010318
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/devel/ruby-optparse
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+do-install:
+ cd ${WRKSRC} && ${RUBY} install.rb
+ ${MKDIR} ${PREFIX}/share/zsh/site-functions
+ ${INSTALL_DATA} ${WRKSRC}/misc/zsh/* ${PREFIX}/share/zsh/site-functions/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/${PORTNAME}/
+.endif
+
+.include <bsd.port.mk>