summaryrefslogtreecommitdiff
path: root/sysutils/portupgrade-devel/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-10-24 13:08:20 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-10-24 13:08:20 +0000
commit145882753d805f2e9105d870562b95a029caea43 (patch)
treeab459bd18266234979f8a53e0afca9e2711a45be /sysutils/portupgrade-devel/Makefile
parentsync with fixed xemacs21-mule. (diff)
Update to 20011024.
portupgrade, portversion, pkg_deinstall, pkg_glob: Introduce the configuration file `pkgtools.conf' for the pkgtools suite. Currently portupgrade(1), portversion(1), pkg_deinstall(1) and pkg_glob(1) use it. Add a new option -q/--no-config to avoid reading the configuration file. Introduce dependency sanity checks. If an inconsistency is detected, immediately abort a process suggesting the user should run `pkgdb -F'. Add a new option -O/--omit-check to omit the sanity checks. pkgdb: Fix the origin guesser's minor bug when the origin port directory does not exist. portupgrade: Add a new option -y/--yes, which lets portupgrade assume user answers yes to all the questions. Make sure to ask user where it should. (Get -N and -i right) Fix a bug where portinstall -i didn't work interactively. [Submitted by: Gregory Neil Shapiro <gshapiro@gshapiro.net>] portsdb: Attempt to offer fast INDEX generation. Now it generates an INDEX file more than a few minutes faster. overall: Emit a warning when pkgdb cannot be updated though it is not up-to-date. Finally remove -E/--regex. Use the ':RE' glob pattern instead.
Diffstat (limited to 'sysutils/portupgrade-devel/Makefile')
-rw-r--r--sysutils/portupgrade-devel/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/sysutils/portupgrade-devel/Makefile b/sysutils/portupgrade-devel/Makefile
index 07e30915e5ff..c6e0850a2257 100644
--- a/sysutils/portupgrade-devel/Makefile
+++ b/sysutils/portupgrade-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= portupgrade
-PORTVERSION= 20011015
+PORTVERSION= 20011024
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://www.iDaemons.org/distfiles/
@@ -70,6 +70,9 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/misc/tcsh/* ${EXAMPLESDIR}/tcsh/
# Remove old database
${RM} -f /var/db/pkg/pkgdb.byfile.db
+ if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
+ fi
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for f in ${DOCS}