summaryrefslogtreecommitdiff
path: root/sysutils/pib/Makefile
diff options
context:
space:
mode:
authorMike Smith <msmith@FreeBSD.org>1996-12-30 09:16:56 +0000
committerMike Smith <msmith@FreeBSD.org>1996-12-30 09:16:56 +0000
commit40105b68bf877f5db4392a0ab792d13a4562ebc0 (patch)
tree52d5d410df16817a7da8b945f245c4a883e9981b /sysutils/pib/Makefile
parentTypo. (sort of.) (diff)
This is PIB, the Ports Index Browser, a GUI tool for manipulating the
FreeBSD ports collection. It provides facilities for tracking distfiles, searching for ports, building etc. Requires bsd.port.mk revision 1.232 or later and a matching ports collection.
Diffstat (limited to 'sysutils/pib/Makefile')
-rw-r--r--sysutils/pib/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/sysutils/pib/Makefile b/sysutils/pib/Makefile
new file mode 100644
index 000000000000..16ff9cff3c93
--- /dev/null
+++ b/sysutils/pib/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: pib
+# Version required: 1.0
+# Date created: 30 December 1996
+# Whom: Mike Smith <msmith@freebsd.org>
+#
+# $Id$
+#
+
+DISTNAME= pib-1.0
+MASTER_SITES= ftp://gsoft.com.au/pib/pib
+CATEGORIES= sysutils
+
+MAINTAINER= msmith@freebsd.org
+
+RUN_DEPENDS= tk-4.1
+
+.include <bsd.port.mk>
+
+install:
+ ${MKDIR} ${PREFIX}/lib/pib
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.tcl ${PREFIX}/lib/pib
+ ${INSTALL_DATA} ${WRKSRC}/libTkSteal.so* ${PREFIX}/lib/pib
+ ln -s ${PREFIX}/lib/pib/pib.tcl ${PREFIX}/bin/pib
+