summaryrefslogtreecommitdiff
path: root/sysutils/pear-File_Fstab/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-03-11 16:29:30 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-03-11 16:29:30 +0000
commit433040be213dffcdda4fd8dc8241655a1bbd4ade (patch)
treeea5a3a44ef01bec360c1bb816bc6010a172e3614 /sysutils/pear-File_Fstab/Makefile
parentAdd mail/qmail-spamcontrol slave port: qmail MTA + SpamControl patches (diff)
New port: sysutils/pear-File_Fstab PEAR class to read and write fstab files
PEAR::File_Fstab is an easy-to-use package which can read & write UNIX fstab files. It presents a pleasant object-oriented interface to the fstab. Features: * Supports blockdev, label, and UUID specification of mount device. * Extendable to parse non-standard fstab formats by defining a new Entry class for that format. * Easily examine and set mount options for an entry. * Stable, functional interface. * Fully documented with PHPDoc. PR: ports/78631 Submitted by: Antonio Carlos Venancio Junior <antonio@php.net>
Diffstat (limited to 'sysutils/pear-File_Fstab/Makefile')
-rw-r--r--sysutils/pear-File_Fstab/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/sysutils/pear-File_Fstab/Makefile b/sysutils/pear-File_Fstab/Makefile
new file mode 100644
index 000000000000..6fda8f3a9a95
--- /dev/null
+++ b/sysutils/pear-File_Fstab/Makefile
@@ -0,0 +1,33 @@
+# Ports collection makefile for: pear-File_Fstab
+# Date created: 09 March 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= File_Fstab
+PORTVERSION= 2.0.1
+CATEGORIES= sysutils devel pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR class to read and write fstab files
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= File
+FILES= Fstab.php Fstab/Entry.php
+EXAMPLES= example.php
+_EXAMPLESDIR= .
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/Fstab
+ @${MV} ${WRKSRC}/Entry.php ${WRKSRC}/Fstab
+.for file in ${FILES}
+ @${REINPLACE_CMD} -e "s|@package@|${PORTNAME}|" ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -e "s|@version@|${PORTVERSION}|" ${WRKSRC}/${file}
+.endfor
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>