summaryrefslogtreecommitdiff
path: root/sysutils/nautilus-cd-burner/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
commite18151212d3326dbf04797c6d5300fb1211ee875 (patch)
tree1ca56d6a4227efdb653cc8e2b2cbedbbc8de3d88 /sysutils/nautilus-cd-burner/Makefile
parentAdd bsdav 1.3, BSD native set of programs for audio and video reading (diff)
Presenting GNOME 2.12 for FreeBSD. The release is chock full of bug fixes
and new features. Don't believe me? Then see for yourself at http://www.gnome.org/start/2.12/notes/en/. DO NOT USE portupgrade by itself to upgrade to GNOME 2.12. Instead, use the gnome_upgrade.sh script from http://www.marcuscom.com/downloads/gnome_upgrade212.sh. This script will circumvent some potential pitfalls users can see if they use portupgrade by itself. In keeping with tradition, GNOME 2.12 for FreeBSD comes with a special splash screen. The winner of this release's contest is Dominique Goncalves <dominique.goncalves@gmail.com>. His splash screen was inspired by http://art.gnome.org/contests/2.12-splash/83. The FreeBSD GNOME Team would lank to thank the following users for their contributions to this release: Matthew Luckie <mjl@luckie.org.nz> ade sajd on #freebsd-gnome Caelian on #freebsd-gnome mnag Yasuda Keisuke <kysd@po.harenet.ne.jp> Mark Hobden <markhobden@gmail.com> Sergey Akifyev <asa@agava.com> Andreas Kohn For more information on GNOME on FreeBSD, checkout http://www.FreeBSD.org/gnome/. The 2.12 documentation will be posted shortly.
Diffstat (limited to 'sysutils/nautilus-cd-burner/Makefile')
-rw-r--r--sysutils/nautilus-cd-burner/Makefile27
1 files changed, 13 insertions, 14 deletions
diff --git a/sysutils/nautilus-cd-burner/Makefile b/sysutils/nautilus-cd-burner/Makefile
index a9af98dde82f..0ed17b7fecbd 100644
--- a/sysutils/nautilus-cd-burner/Makefile
+++ b/sysutils/nautilus-cd-burner/Makefile
@@ -3,49 +3,48 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/sysutils/nautilus-cd-burner/Makefile,v 1.77 2005/10/03 23:36:08 marcus Exp $
#
PORTNAME= nautilus-cd-burner
-PORTVERSION= 2.10.2
+PORTVERSION= 2.12.1
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.10
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.12
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= CD burner view for Nautilus
-RUN_DEPENDS= cdrecord:${PORTSDIR}/sysutils/cdrtools-cjk
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNOME_DESKTOP_VERSION=2
USE_GNOME= gnomeprefix gnomehack intlhack nautilus2
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= ncb.schemas
+OPTIONS= DVD "Enable DVD support" on \
+ CJK "Use cdrtools-cjk instead of cdrtools" off
+
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/bin/growisofs)
-WITH_DVD= yes
+.if defined(WITH_CJK)
+RUN_DEPENDS+= cdrecord:${PORTSDIR}/sysutils/cdrtools-cjk
+WITHOUT_DVD= yes
+.else
+RUN_DEPENDS+= cdrecord:${PORTSDIR}/sysutils/cdrtools
.endif
-.if defined(WITH_DVD)
+.if !defined(WITHOUT_DVD)
RUN_DEPENDS+= growisofs:${PORTSDIR}/sysutils/dvd+rw-tools
.endif
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "${PORTNAME} has the following configurable option(s):"
- @${ECHO_MSG} " WITH_DVD Enable DVD burning support"
- @${ECHO_MSG} ""
-
post-install:
@${CAT} ${PKGMESSAGE}