summaryrefslogtreecommitdiff
path: root/sysutils/munin-node
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2007-10-22 12:32:25 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2007-10-22 12:32:25 +0000
commit3c3af9f5c50e79bc570fc13095f7c76bf4271345 (patch)
tree2e068fee86b239ec569baba106a612684ac02125 /sysutils/munin-node
parentThe first category must be a physical category to make (diff)
Fix some style issues (files -> ${FILESDIR}, pkg-install -> ${PKGINSTALL})
Adjust patches so PATCH_STRIP is not needed Fix default config so hddtemp_smartctl works out of the box
Diffstat (limited to 'sysutils/munin-node')
-rw-r--r--sysutils/munin-node/Makefile8
-rw-r--r--sysutils/munin-node/files/patch-Makefile.config4
-rw-r--r--sysutils/munin-node/files/patch-hddtemp_smartctl.in13
-rw-r--r--sysutils/munin-node/files/patch-munin-node.conf.in4
-rw-r--r--sysutils/munin-node/files/plugins.conf4
5 files changed, 25 insertions, 8 deletions
diff --git a/sysutils/munin-node/Makefile b/sysutils/munin-node/Makefile
index 5ef9f680eaec..838ecc27e3dd 100644
--- a/sysutils/munin-node/Makefile
+++ b/sysutils/munin-node/Makefile
@@ -7,6 +7,7 @@
PORTNAME= munin
PORTVERSION= 1.2.5
+PORTREVISION= 1
CATEGORIES= sysutils perl5
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= munin
@@ -28,7 +29,6 @@ RUN_DEPENDS+= ${SITE_PERL}/Net/Domain.pm:${PORTSDIR}/net/p5-Net
.endif
USE_GMAKE= yes
-PATCH_STRIP= -p1
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.r/rc/}
PKGMESSAGE= ${WRKDIR}/pkg-message
ALL_TARGET= DATADIR=${DATADIR} PERL=${PERL} build build-man
@@ -43,7 +43,7 @@ SUB_LIST= RC_SUBR=${RC_SUBR}
USE_RC_SUBR= YES
pre-install:
- @PKG_PREFIX=${PREFIX} ${SH} pkg-install ${PKGNAME} PRE-INSTALL
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/munin-node.sh ${PREFIX}/etc/rc.d/munin-node.sh
@@ -51,7 +51,7 @@ post-install:
${INSTALL_SCRIPT} ${WRKDIR}/munin-node-revive.sh ${PREFIX}/bin/munin-node-revive
.endif
${INSTALL_DATA} ${WRKSRC}/build/node/munin-node.conf ${PREFIX}/etc/munin/munin-node.conf.sample
- ${INSTALL_DATA} files/plugins.conf ${PREFIX}/etc/munin/plugin-conf.d/plugins.conf.sample
+ ${INSTALL_DATA} ${FILESDIR}/plugins.conf ${PREFIX}/etc/munin/plugin-conf.d/plugins.conf.sample
@if [ ! -f ${PREFIX}/etc/munin/plugin-conf.d/plugins.conf ]; then \
${INSTALL_DATA} ${PREFIX}/etc/munin/plugin-conf.d/plugins.conf.sample ${PREFIX}/etc/munin/plugin-conf.d/plugins.conf; \
fi
@@ -60,7 +60,7 @@ post-install:
@${INSTALL_MAN} -C ${WRKSRC}/build/doc/munin-node-configure.8 ${PREFIX}/man/man8
@${INSTALL_MAN} -C ${WRKSRC}/build/doc/munin-node.8 ${PREFIX}/man/man8
@${INSTALL_MAN} -C ${WRKSRC}/build/doc/munin-run.8 ${PREFIX}/man/man8
- @PKG_PREFIX=${PREFIX} ${SH} pkg-install ${PKGNAME} POST-INSTALL
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO} ${DISTNAME} | ${SED} -e 's/munin_//' > ${PREFIX}/etc/munin/VERSION.node
.include <bsd.port.post.mk>
diff --git a/sysutils/munin-node/files/patch-Makefile.config b/sysutils/munin-node/files/patch-Makefile.config
index 3707764900c3..c0f220e4e13f 100644
--- a/sysutils/munin-node/files/patch-Makefile.config
+++ b/sysutils/munin-node/files/patch-Makefile.config
@@ -1,5 +1,5 @@
---- munin-1.2.0rc2.orig/Makefile.config 2005-01-10 11:38:32.000000000 +0100
-+++ munin-1.2.0rc2/Makefile.config 2005-02-03 11:55:51.000000000 +0100
+--- Makefile.config.orig 2005-01-10 11:38:32.000000000 +0100
++++ Makefile.config 2005-02-03 11:55:51.000000000 +0100
@@ -7,52 +7,56 @@
#
# the base of the Munin installation.
diff --git a/sysutils/munin-node/files/patch-hddtemp_smartctl.in b/sysutils/munin-node/files/patch-hddtemp_smartctl.in
new file mode 100644
index 000000000000..47c38d0eab7b
--- /dev/null
+++ b/sysutils/munin-node/files/patch-hddtemp_smartctl.in
@@ -0,0 +1,13 @@
+--- node/node.d/hddtemp_smartctl.in.orig 2006-10-17 14:27:35.000000000 +0200
++++ node/node.d/hddtemp_smartctl.in 2007-10-04 09:29:43.931425624 +0200
+@@ -109,6 +109,10 @@
+ @drives = grep /hd[a-z]/, readdir IDE;
+ closedir(IDE);
+ }
++} elsif ($^O eq 'freebsd') {
++ opendir(DEV, '/dev');
++ @drives = grep /^ad[0-9]+$/, readdir DEV;
++ closedir(DEV);
+ } elsif ($^O eq 'solaris') {
+ @drives = map { s@.*/@@ ; $_ } glob '/dev/rdsk/c*t*d*s2';
+ }
diff --git a/sysutils/munin-node/files/patch-munin-node.conf.in b/sysutils/munin-node/files/patch-munin-node.conf.in
index 535618ec792d..c09e0fa11415 100644
--- a/sysutils/munin-node/files/patch-munin-node.conf.in
+++ b/sysutils/munin-node/files/patch-munin-node.conf.in
@@ -1,5 +1,5 @@
---- munin-1.0.0pre1.orig/node/munin-node.conf.in Thu Jan 15 15:28:57 2004
-+++ munin-1.0.0pre1/node/munin-node.conf.in Sun Jan 25 14:26:15 2004
+--- node/munin-node.conf.in.orig Thu Jan 15 15:28:57 2004
++++ node/munin-node.conf.in Sun Jan 25 14:26:15 2004
@@ -12,7 +12,7 @@
# Which port to bind to;
host *
diff --git a/sysutils/munin-node/files/plugins.conf b/sysutils/munin-node/files/plugins.conf
index 1ffa23a2f963..b4f2fb6bae2c 100644
--- a/sysutils/munin-node/files/plugins.conf
+++ b/sysutils/munin-node/files/plugins.conf
@@ -35,6 +35,10 @@ env.leasefile /var/db/dhcpd.leases
group mail
env.exim /usr/local/sbin/exim
+[hddtemp_smartctl]
+group operator
+env.smartctl = /usr/local/sbin/smartctl
+
[mysql*]
env.mysqladmin /usr/local/bin/mysqladmin
env.mysqlshow /usr/local/bin/mysqlshow