summaryrefslogtreecommitdiff
path: root/sysutils/komparator/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2006-01-20 23:01:24 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2006-01-20 23:01:24 +0000
commitd1a95a57d99785f30e17d58cf348d667de9a0bab (patch)
tree7220a792287f9d06d84249ac3a56318c3d4fbc30 /sysutils/komparator/Makefile
parent- Properly treat v310.pre configuration file (diff)
Add komparator, an application to synchronizes two directories.
It discovers duplicate, newer or missing files. PR: 92015 Submitted by: Alexander V. Ribchansky <triosoft@triosoft.com.ua>
Diffstat (limited to 'sysutils/komparator/Makefile')
-rw-r--r--sysutils/komparator/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/komparator/Makefile b/sysutils/komparator/Makefile
new file mode 100644
index 000000000000..710895f4dee8
--- /dev/null
+++ b/sysutils/komparator/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: komparator
+# Date created: 18 Jan 2006
+# Whom: Alexander V. Ribchansky <triosoft@triosoft.com.ua>
+#
+# $FreeBSD$
+
+PORTNAME= komparator
+PORTVERSION= 0.2
+CATEGORIES= sysutils kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= triosoft@triosoft.com.ua
+COMMENT= KDE app that searches and synchronizes two directories
+
+USE_KDELIBS_VER= 3
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+DOCSDIR= ${PREFIX}/share/doc/HTML/en/komparator
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,-O2,,g ; \
+ s,-lpthread,${PTHREAD_LIBS},g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+post-configure:
+.if defined(NOPORTDOCS)
+ ${REINPLACE_CMD} -e 's|doc po src|po src|g' ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.mk>