summaryrefslogtreecommitdiff
path: root/sysutils/kkbswitch/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-11-14 13:50:46 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-11-14 13:50:46 +0000
commit4829f821c806c39ad69b85fcb9bf1640dc4b0313 (patch)
tree9e9e60f37451e1a1563c7e02c2e0546d2e118f88 /sysutils/kkbswitch/Makefile
parent*******************IMPORTANT******************* (diff)
Add kkbswitch, a KDE keyboard layout switcher. This one is very similar
to the one delivered with kde, but according to the submitter works a lot better with russian keyboards PR: 58616 Submitted by: Rashid N. Achilov <shelton@sentry.granch.ru>
Diffstat (limited to 'sysutils/kkbswitch/Makefile')
-rw-r--r--sysutils/kkbswitch/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/sysutils/kkbswitch/Makefile b/sysutils/kkbswitch/Makefile
new file mode 100644
index 000000000000..34f1296a1641
--- /dev/null
+++ b/sysutils/kkbswitch/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: kkbswitch
+# Date created: 01 Oct 2003
+# Whom: Rashid N. Achilov <shelton@granch.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kkbswitch
+PORTVERSION= 1.3
+CATEGORIES= sysutils kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= kkbswitch
+
+MAINTAINER= shelton@granch.ru
+COMMENT= Keyboard layout switcher and indicator for KDE 3.x
+
+USE_KDELIBS_VER= 3
+USE_GMAKE= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS += --with-qt-dir=${QT_PREFIX} \
+ --with-extra-includes=${LOCALBASE}/include \
+ --with-extra-libs=${LOCALBASE}/lib
+
+CONFIGURE_TARGET=
+
+PLIST_SUB= PREFIX=${PREFIX} \
+ X11BASE=${X11BASE}
+
+.include <bsd.port.mk>