summaryrefslogtreecommitdiff
path: root/sysutils/hachoir-subfile/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-07-13 18:04:23 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-07-13 18:04:23 +0000
commite616e021d52e0ba0821104f7daab5f50bdd70e1f (patch)
tree120548c0209d805fb47b780ca900f49ca93389b9 /sysutils/hachoir-subfile/Makefile
parent- Update MASTER_SITES (subdirectory change in URL). (diff)
- Update hachoir suite:
- core to 1.0.1 [1] - parser to 1.0 [2] - metadata to 1.0.1 - urwid to 1.0.1 [3] - Transfer maintainership to lwhsu - Add regex and subfile: hachoir-regex is a Python library for regular expression manupulation. You can use a|b (or) and a+b (and) operators. Expressions are optimized during the construction: merge ranges, simplify repetitions, etc. It also contains a class for pattern matching allowing to search multiple strings and regex at the same time. WWW: http://hachoir.org/wiki/hachoir-regex hachoir-subfile is a tool based on hachoir-parser to find subfiles in any binary stream. WWW: http://hachoir.org/wiki/hachoir-subfile PR: ports/114557 [1], ports/114558 [2], ports/114559 [3] Submitted by: lwhsu [1], [2], [3]
Diffstat (limited to 'sysutils/hachoir-subfile/Makefile')
-rw-r--r--sysutils/hachoir-subfile/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/sysutils/hachoir-subfile/Makefile b/sysutils/hachoir-subfile/Makefile
new file mode 100644
index 000000000000..2d4890acc8a5
--- /dev/null
+++ b/sysutils/hachoir-subfile/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: hachoir-subfile
+# Date created: 13 July 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hachoir-subfile
+PORTVERSION= 0.5.2
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP CENKES
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= Find subfiles in any binary stream
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/hachoir_parser/__init__.py:${PORTSDIR}/devel/hachoir-parser \
+ ${PYTHON_SITELIBDIR}/hachoir_regex/__init__.py:${PORTSDIR}/devel/hachoir-regex
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>