summaryrefslogtreecommitdiff
path: root/sysutils/gnomecontrolcenter2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-05-08 22:35:43 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-05-08 22:35:43 +0000
commite68ba8be55f5ef2bbcab8e670c8c6054fe7eaac5 (patch)
tree69966358585d72860a02fb2430a99faea3d02bd4 /sysutils/gnomecontrolcenter2/Makefile
parentAdd gnomeutils2 after repo copy from gnomeutils. These are miscellaneous (diff)
Add gnomecontrolcenter2 after repo copy from gnomecontrolcenter. This
is the configuration frontend for the GNOME 2.0 desktop.
Diffstat (limited to 'sysutils/gnomecontrolcenter2/Makefile')
-rw-r--r--sysutils/gnomecontrolcenter2/Makefile26
1 files changed, 13 insertions, 13 deletions
diff --git a/sysutils/gnomecontrolcenter2/Makefile b/sysutils/gnomecontrolcenter2/Makefile
index 06b89691fae7..15590ba11077 100644
--- a/sysutils/gnomecontrolcenter2/Makefile
+++ b/sysutils/gnomecontrolcenter2/Makefile
@@ -1,38 +1,38 @@
-# New ports collection makefile for: control-center
-# Date created: 29 Dec 1998
-# Whom: Vanilla I. Shu <vanilla@FreeBSD.org>
+# New ports collection makefile for: gnomecontrolcenter2
+# Date created: 04 May 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= gnomecontrolcenter
-PORTVERSION= 1.4.0.5
-PORTREVISION= 1
+PORTNAME= gnomecontrolcenter2
+PORTVERSION= 1.99.9
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= stable/sources/control-center
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-20020501
DISTNAME= control-center-${PORTVERSION}
-DIST_SUBDIR= gnome
+DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= gnomecanvaspixbuf.1:${PORTSDIR}/graphics/gnomecanvas \
- gnomevfs.0:${PORTSDIR}/devel/gnomevfs
+LIB_DEPENDS= gnome-desktop-2.0:${PORTSDIR}/x11/gnomedesktop
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOMELIBS= yes
-INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(libdir\)/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>