summaryrefslogtreecommitdiff
path: root/sysutils/fusefs-smbnetfs/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-08-28 20:41:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-08-28 20:41:33 +0000
commit55ae413eca29e228d1868963eff2aa8134cae3f6 (patch)
tree48b7744faf29faa2c7bf609b7ba794520b4b0ded /sysutils/fusefs-smbnetfs/Makefile
parent- Register UID/GID 128 for vserver (diff)
SMBNetFS is a filesystem that allow you to use samba/microsoft network
in the same manner as the network neighborhood in Microsoft Windows. Featuries: * you can use Samba/Microsoft network as a regular unix filesystem * workgroup/computer/share entries are dynamically created * windows domain supported * kerberos support (New) * user defined workgroup/link/hosts are supported * national character supported * in config files you can specify different user/password to access different network shares * you can access any computer in the world by "cd mountpoint/ip-addr" command, where "ip-addr" is the IP address of the desired computer. Do not warry that there is no file with such name :-) * command "cd mountpoint/username:password@computer_or_ip" allows you to access "computer_or_ip" as user "username" with password "password" (this is insecure, but usefull) WWW: http://sourceforge.net/projects/smbnetfs PR: ports/101451 Submitted by: Denis Barov <dindin@freebsd.org.ua>
Diffstat (limited to 'sysutils/fusefs-smbnetfs/Makefile')
-rw-r--r--sysutils/fusefs-smbnetfs/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/sysutils/fusefs-smbnetfs/Makefile b/sysutils/fusefs-smbnetfs/Makefile
new file mode 100644
index 000000000000..756ca557705b
--- /dev/null
+++ b/sysutils/fusefs-smbnetfs/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: smbnetfs
+# Date created: 06 August 2006
+# Whom: Denis Barov
+# $FreeBSD$
+#
+
+PORTNAME= smbnetfs
+PORTVERSION= 0.3.6
+CATEGORIES= sysutils net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= fusefs-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= dindin@freebsd.org.ua
+COMMENT= Mount smb shares (Fuse filesystem)
+
+LIB_DEPENDS= fuse.2:${PORTSDIR}/sysutils/fusefs-libs \
+ smbclient.0:${PORTSDIR}/net/samba-libsmbclient
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+BUILD_DEPENDS= fusefs-libs>2.4.1:${PORTSDIR}/sysutils/fusefs-libs
+
+USE_BZIP2= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include"
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+IGNORE= depends on kernel module that requires FreeBSD 6 or later
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>