summaryrefslogtreecommitdiff
path: root/sysutils/fusefs-libs/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-18 19:48:56 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-18 19:48:56 +0000
commitcad1fb9d4025e32af822a692d5f48c9e2e2f5815 (patch)
tree822cb438b89ea4d99ecee752ea15cde1c91a7571 /sysutils/fusefs-libs/Makefile
parent- new default gcc34 (diff)
- Update fusefs-kmod to 0.2.99.1, fusefs-libs to 2.5.0, fusefs-sshfs to 1.4
PR: ports/91873 Submitted by: Anish Mistry <amistry@am-productions.biz> (maintainer)
Diffstat (limited to 'sysutils/fusefs-libs/Makefile')
-rw-r--r--sysutils/fusefs-libs/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/sysutils/fusefs-libs/Makefile b/sysutils/fusefs-libs/Makefile
index 2e3d1cda5f9c..291f3ba7b0ec 100644
--- a/sysutils/fusefs-libs/Makefile
+++ b/sysutils/fusefs-libs/Makefile
@@ -5,7 +5,7 @@
#
PORTNAME= fusefs
-PORTVERSION= 2.4.1
+PORTVERSION= 2.5.0
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= fuse
@@ -17,12 +17,14 @@ COMMENT= FUSE allows filesystem implementation in userspace
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= MOUNT_FUSE_PATH=${PREFIX}/sbin \
- PKG_CONFIG_PATH=${PREFIX}/libdata/pkgconfig \
CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --disable-kernel-module --prefix=${PREFIX}
+CONFIGURE_ARGS= --disable-kernel-module --prefix=${PREFIX} \
+ --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
USE_REINPLACE= yes
+TXT_DOCS= how-fuse-works \
+ kernel.txt
.include <bsd.port.pre.mk>
@@ -41,4 +43,11 @@ post-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/include/fuse_kernel.h ${PREFIX}/include/fuse
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}/libs
+.for i in ${TXT_DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/doc/$i ${DOCSDIR}/libs
+.endfor
+.endif
+
.include <bsd.port.post.mk>