summaryrefslogtreecommitdiff
path: root/sysutils/fusefs-libs/Makefile
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-10-19 08:14:55 +0000
committerSimon Barner <barner@FreeBSD.org>2005-10-19 08:14:55 +0000
commit8eb435d9d1301d5d6bcfc0ff46031b1889c6cd26 (patch)
tree874dc287d18d57d4564ab2c29402075aec275be8 /sysutils/fusefs-libs/Makefile
parentUpdate to 2.2.10.alpha. (diff)
Add new port for the fuse libraries:
FUSE makes it possible to implement a filesystem in a userspace program. Features include: simple yet comprehensive API, secure mounting by non-root users, support for RELENG_6 and HEAD FreeBSD kernels, multi-threaded operation. WWW: http://sourceforge.net/projects/fuse/ PR: ports/87167 Submitted by: Anish Mistry <amistry@am-productions.biz> Reviewed by: Csaba Henk <csaba.henk@creo.hu> (fuse SoC participant)
Diffstat (limited to 'sysutils/fusefs-libs/Makefile')
-rw-r--r--sysutils/fusefs-libs/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/sysutils/fusefs-libs/Makefile b/sysutils/fusefs-libs/Makefile
new file mode 100644
index 000000000000..ace12b176d4e
--- /dev/null
+++ b/sysutils/fusefs-libs/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: fusefs-libs
+# Date created: 01 October 2005
+# Whom: Anish Mistry
+# $FreeBSD$
+#
+
+PORTNAME= fusefs
+PORTVERSION= 2.4.0
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= fuse
+PKGNAMESUFFIX= -libs
+DISTNAME= fuse-${PORTVERSION}
+
+MAINTAINER= amistry@am-productions.biz
+COMMENT= FUSE allows filesystem implementation in userspace
+
+USE_LIBTOOL_VER=15
+CONFIGURE_ENV= MOUNT_FUSE_PATH=${PREFIX}/sbin \
+ PKG_CONFIG_PATH=${PREFIX}/libdata/pkgconfig \
+ CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --disable-kernel-module --prefix=${PREFIX}
+USE_REINPLACE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+IGNORE= Depends on kernel module that requires FreeBSD 6 or later
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,-lpthread,${PTHREAD_LIBS},' \
+ -e 's,-D_FILE_OFFSET_BITS=64,-D_FILE_OFFSET_BITS=64 ${PTHREAD_CFLAGS},' \
+ ${WRKSRC}/fuse.pc.in
+ ${REINPLACE_CMD} -e 's,-lpthread,${PTHREAD_LIBS},' \
+ ${WRKSRC}/lib/Makefile.in \
+ ${WRKSRC}/example/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/include/fuse_kernel.h ${PREFIX}/include/fuse
+
+.include <bsd.port.post.mk>