summaryrefslogtreecommitdiff
path: root/sysutils/f3/Makefile
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2014-09-27 01:46:53 +0000
committerJason E. Hale <jhale@FreeBSD.org>2014-09-27 01:46:53 +0000
commit632d49652883972897de0acdc859e620ecd271e4 (patch)
treeb778c9069a9d45365eb87914a3a45ae3934da871 /sysutils/f3/Makefile
parentInstall scan-view dependencies. (diff)
F3 (Fight Flash Fraud or Fight Fake Flash) tests the full capacity
of a flash card (flash drive, flash disk, pendrive). It writes to the card and then checks if it can read it. It will assure that you haven't been sold a card with a smaller capacity than stated. WARNING: All data on the tested disk might be lost! WWW: http://oss.digirati.com.br/f3 PR: 193779 Submitted by: Uffe Jakobsen <uffe@uffe.org>
Diffstat (limited to 'sysutils/f3/Makefile')
-rw-r--r--sysutils/f3/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/f3/Makefile b/sysutils/f3/Makefile
new file mode 100644
index 000000000000..d4ee264b175a
--- /dev/null
+++ b/sysutils/f3/Makefile
@@ -0,0 +1,32 @@
+# Created by: Uffe Jakobsen <uffe@uffe.org>
+# $FreeBSD$
+
+PORTNAME= f3
+PORTVERSION= 4.0
+CATEGORIES= sysutils
+
+MAINTAINER= uffe@uffe.org
+COMMENT= Fight Flash Fraud or Fight Fake Flash test tool
+
+LICENSE= GPLv3
+
+USE_GITHUB= yes
+GH_ACCOUNT= AltraMayor
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 55d2017
+
+USES= gmake pathfix shebangfix
+
+SHEBANG_FILES= f3write.h2w log-f3wr
+
+PLIST_FILES= bin/f3read bin/f3write bin/f3write.h2w \
+ bin/log-f3wr man/man1/f3read.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/f3read ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/f3write ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/f3write.h2w ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/log-f3wr ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/f3read.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>