summaryrefslogtreecommitdiff
path: root/sysutils/eiciel/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-24 19:08:22 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-24 19:08:22 +0000
commitafc3a8d2f7d82e47f4042be931bc2e6a20a864a3 (patch)
tree0b4febeb842f53575b85799be977b37fd7a06af6 /sysutils/eiciel/Makefile
parentUse proper configure args instead of patching source files. (diff)
Add eiciel.
Eiciel allows you to visually edit file ACL entries. You can add and remove users and groups who will be granted permissions through the graphical interface. WWW: http://rofi.pinchito.com/eiciel/ PR: ports/83810 Submitted by: Andreas Kohn <andreas@syndrom23.de>
Diffstat (limited to 'sysutils/eiciel/Makefile')
-rw-r--r--sysutils/eiciel/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/sysutils/eiciel/Makefile b/sysutils/eiciel/Makefile
new file mode 100644
index 000000000000..bfa629f32b04
--- /dev/null
+++ b/sysutils/eiciel/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: eiciel
+# Date created: July 20, 2005
+# Whom: andreas@syndrom23.de
+#
+# $FreeBSD$
+#
+
+PORTNAME= eiciel
+PORTVERSION= 0.7
+CATEGORIES= sysutils security
+MASTER_SITES= http://rofi.pinchito.com/eiciel/download/
+
+MAINTAINER= andreas@syndrom23.de
+COMMENT= A GNOME-based ACL editor, with integration into Nautilus
+
+LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GNOME= gnomeprefix gnomehack intlhack nautilus2
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= libtool:15
+
+MAN1= eiciel.1
+
+.if defined(WITHOUT_NLS)
+PLIST_SUB+= NLS="@comment "
+CONFIGURE_ARGS+= --disable-nls
+.else
+PLIST_SUB+= NLS=""
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= Needs ACL support available in FreeBSD 5.0 and later
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^libeiciel_nautilus_la_LDFLAGS/ s|= |= -avoid-version -module |' \
+ ${WRKSRC}/src/Makefile.in
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>