summaryrefslogtreecommitdiff
path: root/sysutils/disktool/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-07-23 17:00:33 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-07-23 17:00:33 +0000
commitc1ce862de29d4734a257ed077fe175450500cead (patch)
tree787d21f9547efd88cd5ee198fce897518b4d0ed4 /sysutils/disktool/Makefile
parentUnbreak: (diff)
Add disktool 2.0,
xView sysadmin tool for monitoring diskfull situations. PR: 52495 Submitted by: Serge Gagnon <gagnon__s@videotron.ca>
Diffstat (limited to 'sysutils/disktool/Makefile')
-rw-r--r--sysutils/disktool/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/sysutils/disktool/Makefile b/sysutils/disktool/Makefile
new file mode 100644
index 000000000000..f084c38f6ffa
--- /dev/null
+++ b/sysutils/disktool/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: disktool
+# Date created: Thu Apr 24 05:10:34 EDT 2003
+# Whom: Serge Gagnon <gagnon__s@videotron.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= disktool
+PORTVERSION= 2.0
+CATEGORIES= sysutils
+MASTER_SITES= http://ftp.auxio.org/pub/mirrors/step.polymtl.ca/pub/Xview/apps/disktool/ \
+ ftp://quenix.dyndns.org/freebsd/
+DISTNAME= disktool-2.0c
+
+MAINTAINER= gagnon__s@videotron.ca
+COMMENT= XView sysadmin tool for monitoring diskfull situations
+
+LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
+
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+ALL_TARGET= disktool
+
+MAN1= disktool.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/disktool ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/disktool.man \
+ ${PREFIX}/man/man1/disktool.1
+
+.include <bsd.port.mk>