summaryrefslogtreecommitdiff
path: root/shells/pdksh/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2002-05-15 11:49:00 +0000
committerThomas Gellekum <tg@FreeBSD.org>2002-05-15 11:49:00 +0000
commit22263f8e8192a1e823a5112708c4011d60e526b5 (patch)
tree964720a3863646dbaa0c0d37083a2447162b2c0b /shells/pdksh/Makefile
parentSince 2002/02/27 (v. 0.4), bin/xlhtml and bin/ppthtml have been lowercased, (diff)
Include distributed patches.
PR: 38071 Submitted by: Cyrille Lefevre <cyrille.lefevre@laposte.net>
Diffstat (limited to 'shells/pdksh/Makefile')
-rw-r--r--shells/pdksh/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/shells/pdksh/Makefile b/shells/pdksh/Makefile
index a38e18e57a15..588036f30330 100644
--- a/shells/pdksh/Makefile
+++ b/shells/pdksh/Makefile
@@ -6,13 +6,18 @@
#
PORTNAME= pdksh
-PORTVERSION= 5.2.14
+PORTVERSION= 5.2.14.p2
CATEGORIES= shells
MASTER_SITES= ftp://ftp.cs.mun.ca/pub/pdksh/ \
http://gd.tuwien.ac.at/utils/shells/pdksh/ \
ftp://ftp.lip6.fr/pub/unix/shells/pdksh/ \
ftp://ftp.demon.net/pub/mirrors/pdksh/ \
ftp://ftp.rge.com/pub/shells/pdksh/
+DISTNAME= ${PORTNAME}-${PORTVERSION:N*p*}${PORTVERSION:M*p*:R}
+
+PATCH_SITES= ${MASTER_SITES}
+PATCHFILES= ${DISTNAME}-patches.1 ${DISTNAME}-patches.2
+PATCH_DIST_STRIP= -p2
MAINTAINER= tg@FreeBSD.org
@@ -20,6 +25,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= LDSTATIC=-static
MAN1= ksh.1
+post-patch:
+ @(${ECHO_CMD} ",s/v${PORTVERSION:N*p*}${PORTVERSION:M*p*:R} /v${PORTVERSION:S/p//} /"; \
+ ${ECHO_CMD} "wq") | ed -s ${WRKSRC}/version.c
+
post-install:
@${ECHO} "Updating /etc/shells"
@${CP} /etc/shells /etc/shells.bak