summaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-06-08 16:16:49 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-06-08 16:16:49 +0000
commit07db5231ffcfb169aed5716c4ea8b71d5a36c3f3 (patch)
tree08d71d88447574ec5625e4cec83d890252a19641 /security
parentRemove pkg-deinstall. (diff)
Enable pthread support using devel/pth.
Turn on building clamd and clamdscan. PR: 53056 Pointed out by: Olivier Tharan <olive@oban.frmug.org> Submitted by: TERAMOTO Masahiro <markun@onohara.to>
Diffstat (limited to 'security')
-rw-r--r--security/clamav-devel/Makefile6
-rw-r--r--security/clamav-devel/pkg-install4
-rw-r--r--security/clamav-devel/pkg-plist2
-rw-r--r--security/clamav/Makefile6
-rw-r--r--security/clamav/pkg-install4
-rw-r--r--security/clamav/pkg-plist2
6 files changed, 16 insertions, 8 deletions
diff --git a/security/clamav-devel/Makefile b/security/clamav-devel/Makefile
index 4fe6a4c49129..7d7704382fa3 100644
--- a/security/clamav-devel/Makefile
+++ b/security/clamav-devel/Makefile
@@ -19,11 +19,13 @@ RUN_DEPENDS= lha:${PORTSDIR}/archivers/lha \
zoo:${PORTSDIR}/archivers/zoo \
arc:${PORTSDIR}/archivers/arc \
unzip:${PORTSDIR}/archivers/unzip
+LIB_DEPENDS= pth.20:${PORTSDIR}/devel/pth
USE_GMAKE= yes
-HAS_CONFIGURE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --disable-clamav --disable-pthreads
+CONFIGURE_ARGS= --prefix=${PREFIX} --disable-clamav
MAN1= clamscan.1 freshclam.1 sigtool.1 clamdscan.1
MAN5= clamav.conf.5
diff --git a/security/clamav-devel/pkg-install b/security/clamav-devel/pkg-install
index 448ffdc1f34a..4e257bc4ccf7 100644
--- a/security/clamav-devel/pkg-install
+++ b/security/clamav-devel/pkg-install
@@ -4,8 +4,8 @@ if [ "$2" != "PRE-INSTALL" ]; then
exit 0
fi
-USER=clamav
-GROUP=clamav
+USER?=clamav
+GROUP?=clamav
if ! pw groupshow "$GROUP" 2>/dev/null 1>&2; then
if pw groupadd $GROUP; then
diff --git a/security/clamav-devel/pkg-plist b/security/clamav-devel/pkg-plist
index 078a2b5937b2..b919db1eb401 100644
--- a/security/clamav-devel/pkg-plist
+++ b/security/clamav-devel/pkg-plist
@@ -1,6 +1,8 @@
bin/clamscan
+bin/clamdscan
bin/freshclam
bin/sigtool
+sbin/clamd
include/clamav.h
lib/libclamav.so.1
lib/libclamav.so
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 4fe6a4c49129..7d7704382fa3 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -19,11 +19,13 @@ RUN_DEPENDS= lha:${PORTSDIR}/archivers/lha \
zoo:${PORTSDIR}/archivers/zoo \
arc:${PORTSDIR}/archivers/arc \
unzip:${PORTSDIR}/archivers/unzip
+LIB_DEPENDS= pth.20:${PORTSDIR}/devel/pth
USE_GMAKE= yes
-HAS_CONFIGURE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --disable-clamav --disable-pthreads
+CONFIGURE_ARGS= --prefix=${PREFIX} --disable-clamav
MAN1= clamscan.1 freshclam.1 sigtool.1 clamdscan.1
MAN5= clamav.conf.5
diff --git a/security/clamav/pkg-install b/security/clamav/pkg-install
index 448ffdc1f34a..4e257bc4ccf7 100644
--- a/security/clamav/pkg-install
+++ b/security/clamav/pkg-install
@@ -4,8 +4,8 @@ if [ "$2" != "PRE-INSTALL" ]; then
exit 0
fi
-USER=clamav
-GROUP=clamav
+USER?=clamav
+GROUP?=clamav
if ! pw groupshow "$GROUP" 2>/dev/null 1>&2; then
if pw groupadd $GROUP; then
diff --git a/security/clamav/pkg-plist b/security/clamav/pkg-plist
index 078a2b5937b2..b919db1eb401 100644
--- a/security/clamav/pkg-plist
+++ b/security/clamav/pkg-plist
@@ -1,6 +1,8 @@
bin/clamscan
+bin/clamdscan
bin/freshclam
bin/sigtool
+sbin/clamd
include/clamav.h
lib/libclamav.so.1
lib/libclamav.so