summaryrefslogtreecommitdiff
path: root/security/tripwire-131
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2002-02-20 14:47:04 +0000
committerCy Schubert <cy@FreeBSD.org>2002-02-20 14:47:04 +0000
commit12df4b76d3f67b893d13c983cc176b98d20a6b2f (patch)
tree79cf3e3718cb1e094123fa59c2027d28c7e3409e /security/tripwire-131
parentUpdate pkg-plist (diff)
Add configuration options to Tripwire 1.3.1 install:
- Add the TWCONFIG variable to install a user defined tw.config instead of the one supplied with the port. - Add the NO_DB_BUILD variable to skip the database build during install for users upgrading or reinstalling the port who wish to use an existing or previously installed Tripwire database. Change MAINTAINER from me (Cy.Schubert@uumail.gov.bc.ca) to me (cy@FreeBSD.org). PR: ports/35127 Submitted by: cjc
Diffstat (limited to 'security/tripwire-131')
-rw-r--r--security/tripwire-131/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/security/tripwire-131/Makefile b/security/tripwire-131/Makefile
index 7280327ce353..b4346cea05b5 100644
--- a/security/tripwire-131/Makefile
+++ b/security/tripwire-131/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 1.3.1
CATEGORIES= security
DISTNAME= Tripwire-${PORTVERSION}-1
-MAINTAINER= Cy.Schubert@uumail.gov.bc.ca
+MAINTAINER= cy@FreeBSD.org
MAN5= tw.config.5
MAN8= siggen.8 tripwire.8
@@ -19,6 +19,8 @@ NO_PACKAGE= "requires local database to be built"
RESTRICTED= "contains crypto class algorithms"
WRKSRC= ${WRKDIR}/tw_ASR_1.3.1_src
+TWCONFIG?= ${FILESDIR}/tw.conf.freebsd2
+
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
@@ -27,11 +29,12 @@ IGNORE='Please read http://www.tripwiresecurity.com/ for details of how to obtai
pre-configure:
@ ${CP} ${FILESDIR}/conf-freebsd2.h ${WRKSRC}/configs
- @ ${CP} ${FILESDIR}/tw.conf.freebsd2 ${WRKSRC}/configs/tw.conf.freebsd2
+ @ ${CP} ${TWCONFIG} ${WRKSRC}/configs/tw.conf.freebsd2
post-install:
@ ${MKDIR} /var/adm/tcheck
- @ ${CP} ${FILESDIR}/tw.conf.freebsd2 /var/adm/tcheck/tw.config
+ @ ${CP} ${TWCONFIG} /var/adm/tcheck/tw.config
+.ifndef NO_DB_BUILD
@ ${ECHO} Creating tripwire database
@ (cd /var/adm/tcheck; tripwire -initialize)
.if defined(TRIPWIRE_FLOPPY) && ${TRIPWIRE_FLOPPY} == YES
@@ -48,5 +51,6 @@ post-install:
@ umount /mnt
@ ${ECHO} Do not forget to remove and write-protect the floppy.
.endif
+.endif
.include <bsd.port.post.mk>