summaryrefslogtreecommitdiff
path: root/security/sig2dot/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-07 08:32:07 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-07 08:32:07 +0000
commit2ee5c985120f9df050a35c496df0d10ec316e30d (patch)
tree03094d965296d53c49c603f9377dc1d4f5bac271 /security/sig2dot/Makefile
parentCorrect KDE2 refs to KDE3. (diff)
add sig2dot 0.27
GPG/PGP Keyring Graph Generator
Diffstat (limited to 'security/sig2dot/Makefile')
-rw-r--r--security/sig2dot/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/security/sig2dot/Makefile b/security/sig2dot/Makefile
new file mode 100644
index 000000000000..e273b0122a8e
--- /dev/null
+++ b/security/sig2dot/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: sig2dot
+# Date created: Aug 8, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= sig2dot
+PORTVERSION= 0.27
+CATEGORIES= security
+MASTER_SITES= http://www.chaosreigns.com/code/sig2dot/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .pl
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ${WRKDIR}
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e "s|/usr/bin/perl|${PERL}|g" ${WRKSRC}/sig2dot.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sig2dot.pl ${PREFIX}/bin/sig2dot
+
+.include <bsd.port.mk>