summaryrefslogtreecommitdiff
path: root/security/pwman/Makefile
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-06-23 21:58:05 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-06-23 21:58:05 +0000
commit4c26a07a1518eeb1958187fd34cbd1a3c04f43f3 (patch)
tree4f6576b214f6f25777d4f9a3289956ac1ba6c659 /security/pwman/Makefile
parentRemove FORBIDDEN, oenssl-0.9.6d doesn't made in into 4.6 RELEASE (diff)
Add pwman, a console password management application.
Diffstat (limited to 'security/pwman/Makefile')
-rw-r--r--security/pwman/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/security/pwman/Makefile b/security/pwman/Makefile
new file mode 100644
index 000000000000..c12518e8ea07
--- /dev/null
+++ b/security/pwman/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: pwman
+# Date created: 23 June 2002
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pwman
+PORTVERSION= 0.2.1
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= anders@FreeBSD.org
+
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+BUILD_DEPENDS= gpgme-config:${PORTSDIR}/security/gpgme
+RUN_DEPENDS= gpgme-config:${PORTSDIR}/security/gpgme
+
+GNU_CONFIGURE= yes
+
+MAN1= pwman.1
+
+DOCS= AUTHORS COPYING ChangeLog README TODO
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${INSTALL} -d -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>