summaryrefslogtreecommitdiff
path: root/security/pks/pkg-install
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2001-01-15 04:40:11 +0000
committerKris Kennaway <kris@FreeBSD.org>2001-01-15 04:40:11 +0000
commit04665ddc392f7965fe98a2d34c10ac90bbe3e0a7 (patch)
tree9d6c8d5d9f5f37a93739230be282fcb6005017c2 /security/pks/pkg-install
parentUpdate xsane to 0.70, update and sort pkg-plist (diff)
pks 0.9.4 is a PGP public key server from MIT.
Obtained from: NetBSD
Diffstat (limited to 'security/pks/pkg-install')
-rw-r--r--security/pks/pkg-install22
1 files changed, 22 insertions, 0 deletions
diff --git a/security/pks/pkg-install b/security/pks/pkg-install
new file mode 100644
index 000000000000..d2c772b14e80
--- /dev/null
+++ b/security/pks/pkg-install
@@ -0,0 +1,22 @@
+#!/bin/sh
+#
+# $NetBSD$
+
+PKGNAME=$1
+STAGE=$2
+
+case ${STAGE} in
+PRE-INSTALL)
+ ;;
+POST-INSTALL)
+ DBDIR=/var/pks/db
+ MAILDIR=/var/pks/incoming
+
+ mkdir -p ${DBDIR} ${MAILDIR}
+ ;;
+*)
+ echo "Unexpected argument: ${STAGE}"
+ exit 1
+ ;;
+esac
+exit 0