summaryrefslogtreecommitdiff
path: root/security/pam_smb/Makefile
diff options
context:
space:
mode:
authorNick Sayer <nsayer@FreeBSD.org>2001-06-20 13:38:56 +0000
committerNick Sayer <nsayer@FreeBSD.org>2001-06-20 13:38:56 +0000
commit9dfb8331051963f5bf7e7d6e7e91be227b84cf9b (patch)
tree497238cd3cab7afaba12f654a11cecdfea4d3817 /security/pam_smb/Makefile
parentUpdate to 0.8.4. (diff)
Add port for pam_smb, an NT domain PAM module
Diffstat (limited to 'security/pam_smb/Makefile')
-rw-r--r--security/pam_smb/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/security/pam_smb/Makefile b/security/pam_smb/Makefile
new file mode 100644
index 000000000000..1391a7d979d3
--- /dev/null
+++ b/security/pam_smb/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: pam_smb
+# Date created: 20 Jun 2001
+# Whom: nsayer
+#
+# $FreeBSD$
+
+PORTNAME= pam_smb
+PORTVERSION= 1.1.6
+CATEGORIES= security
+MASTER_SITES= ftp://ftp.samba.org/pub/samba/%SUBDIR%/ \
+ ftp://ring.asahi-net.or.jp/pub/net/samba/%SUBDIR%/ \
+ ftp://samba.anu.edu.au/pub/samba/%SUBDIR%/ \
+ ftp://de.samba.org/pub/mirror/samba/%SUBDIR%/ \
+ ftp://se.samba.org/pub/samba/%SUBDIR%/ \
+ ftp://ftp.sunet.se/pub/unix/utilities/samba/%SUBDIR%/
+MASTER_SITE_SUBDIR=pam_smb
+
+MAINTAINER= nsayer
+
+USE_AUTOCONF= yes
+USE_GMAKE= yes
+MAKE_ENV+= PREFIX=${PREFIX}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${PERL} -pi -e s%CONFDIR%\"${PREFIX}/etc\"% ${WRKSRC}/pam_read_conf.c
+ ${PERL} -pi -e s%CONFDIR%\"${PREFIX}/etc\"% ${WRKSRC}/pam_smb_auth.c
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/pam_smb_auth.so ${PREFIX}/lib
+ ${INSTALL_DATA} ${FILESDIR}/pam_smb.conf.sample ${PREFIX}/etc
+
+post-install:
+ @${SED} -e 's#%%PREFIX%%#${PREFIX}#g' ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>