summaryrefslogtreecommitdiff
path: root/security/p5-PGP/Makefile
diff options
context:
space:
mode:
authorJames FitzGibbon <jfitz@FreeBSD.org>1996-10-24 08:38:37 +0000
committerJames FitzGibbon <jfitz@FreeBSD.org>1996-10-24 08:38:37 +0000
commit072d72d794f879468a38d4ddee214f4cc816ddb0 (patch)
tree30da9e1f6e7a1bbcd14aa3531172f627fabcdba9 /security/p5-PGP/Makefile
parentperl5 interface to the RSA Data Security Inc. MD5 Message-Digest Algorithm (diff)
perl5 module to work with PGP messages.
Diffstat (limited to 'security/p5-PGP/Makefile')
-rw-r--r--security/p5-PGP/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/security/p5-PGP/Makefile b/security/p5-PGP/Makefile
new file mode 100644
index 000000000000..d3aa0a416446
--- /dev/null
+++ b/security/p5-PGP/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-PGP
+# Version required: 0.2alpha
+# Date created: October 21st 1996
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= PGP-0.2alpha
+PKGNAME= p5-PGP-0.2a
+CATEGORIES+= security
+MASTER_SITES= ftp://ftp.digital.com/pub/plan/perl/CPAN/modules/by-module/PGP/ \
+ ftp://ftp.cdrom.com/pub/perl/CPAN/modules/by-module/PGP/ \
+ ftp://ftp.cis.ufl.edu/pub/perl/CPAN/modules/by-module/PGP/ \
+ ftp://ftp.leo.org/pub/comp/programming/languages/perl/CPAN/modules/by-module/PGP/ \
+ ftp://ftp.demon.co.uk/pub/mirrors/perl/CPAN/modules/by-module/PGP/ \
+ ftp://ftp.lab.kdd.co.jp/lang/perl/CPAN/modules/by-module/PGP/
+
+MAINTAINER= jfitz@FreeBSD.ORG
+
+BUILD_DEPENDS= perl5.003:${PORTSDIR}/lang/perl5 \
+ pgp:${PORTSDIR}/security/pgp
+
+NO_WRKSUBDIR= YES
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+
+post-install:
+.if !defined(NOMANCOMPRESS)
+ @ for file in PGP; do \
+ gzip -9nf ${PREFIX}/lib/perl5/man/man3/$$file.3; \
+ done
+.endif
+
+.include <bsd.port.mk>