summaryrefslogtreecommitdiff
path: root/security/nessus-libraries-devel/Makefile
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2003-04-19 20:37:39 +0000
committerOliver Braun <obraun@FreeBSD.org>2003-04-19 20:37:39 +0000
commit6250f95bc870e2a5aa24a1656c66812f4c1b1baa (patch)
treea1def4445ba39733d42ce67eb7370c6705bd6348 /security/nessus-libraries-devel/Makefile
parentupdate from 1.6.6 to 1.6.7p4 (diff)
- Update to 2.0.4.
- Add dependency on bpf for the server. - Add "client only" knob. PR: ports/51125 Submitted by: maintainer
Diffstat (limited to 'security/nessus-libraries-devel/Makefile')
-rw-r--r--security/nessus-libraries-devel/Makefile39
1 files changed, 38 insertions, 1 deletions
diff --git a/security/nessus-libraries-devel/Makefile b/security/nessus-libraries-devel/Makefile
index 5f638f883fd5..1bf38c519980 100644
--- a/security/nessus-libraries-devel/Makefile
+++ b/security/nessus-libraries-devel/Makefile
@@ -3,8 +3,11 @@
# $FreeBSD$
#
+# Define NESSUS_CLIENT_ONLY if you only want to build this for the nessus
+# client.
+
PORTNAME= nessus-libraries-devel
-PORTVERSION= 2.0.3
+PORTVERSION= 2.0.4
CATEGORIES= security
MASTER_SITES= ftp://ftp.nessus.org/pub/nessus/nessus-${PORTVERSION}/src/ \
ftp://ftp.gwdg.de/pub/linux/misc/nessus/nessus-${PORTVERSION}/src/ \
@@ -24,9 +27,43 @@ USE_BISON= YES
USE_LIBTOOL= YES
CONFIGURE_ARGS= --enable-cipher --sharedstatedir=${PREFIX}/etc/nessus/com \
--localstatedir=${PREFIX}/etc/nessus/var
+.if defined(WITH_NESSUS_BPF_SHARE)
+CONFIGURE_ARGS+= --enable-bpf-sharing
+.endif
INSTALLS_SHLIB= YES
MAN1= nessus-config.1
+.if ! defined(NESSUS_CLIENT_ONLY)
+pre-configure:
+ @if [ ! -c /dev/bpf1 ]; then \
+ ${ECHO} "********************************************************";\
+ ${ECHO} "* W a r n i n g *";\
+ ${ECHO} "* *";\
+ ${ECHO} "* Nessus needs Berkeley Packet Filter (bpf). *";\
+ ${ECHO} "* To use nessus, your kernel must be rebuilt with bpf, *";\
+ ${ECHO} "* and make bpf devices on /dev directory. *";\
+ ${ECHO} "* *";\
+ ${ECHO} "* Be sure to build as many bpf devices as you need. *";\
+ ${ECHO} "* For more info on this read files/README.BPF *";\
+ ${ECHO} "********************************************************";\
+ ${FALSE}; \
+ fi
+.if ! defined(WITH_NESSUS_BPF_SHARE)
+ @if [ ! -c /dev/bpf40 ]; then \
+ ${ECHO} "********************************************************";\
+ ${ECHO} "* W a r n i n g *";\
+ ${ECHO} "* *";\
+ ${ECHO} "* Nessus needs many bpf devices. If you can't rebuild *";\
+ ${ECHO} "* your kernel with more than 40 bpf devices (as *";\
+ ${ECHO} "* described in files/README.BPF) then build this port *";\
+ ${ECHO} "* with \"make -DWITH_NESSUS_BPF_SHARE\" *";\
+ ${ECHO} "* *";\
+ ${ECHO} "********************************************************";\
+ ${FALSE}; \
+ fi
+.endif
+.endif
+
.include <bsd.port.mk>