summaryrefslogtreecommitdiff
path: root/security/clamav/files
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-03-06 20:45:47 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-03-06 20:45:47 +0000
commit8b8a6523a51398f4198e4262f1c237ed0d89f91c (patch)
tree861d44c4216f447b4c981b246cb0222ab065bd5f /security/clamav/files
parentAdjust brokenness message. This is really an install failure, not (diff)
- update to version 0.67-1
PR: 63065 Reviewed by: Angelo Turetta <aturetta@commit.it> Approved by: maintainer timeout (2 weeks)
Diffstat (limited to 'security/clamav/files')
-rw-r--r--security/clamav/files/patch-clamav-milter::Makefile.in9
-rw-r--r--security/clamav/files/patch-configure28
-rw-r--r--security/clamav/files/patch-etc::Makefile.in13
-rw-r--r--security/clamav/files/patch-libclamav::message.c27
4 files changed, 41 insertions, 36 deletions
diff --git a/security/clamav/files/patch-clamav-milter::Makefile.in b/security/clamav/files/patch-clamav-milter::Makefile.in
index bcdc3f2c964c..d6a1bd3f5597 100644
--- a/security/clamav/files/patch-clamav-milter::Makefile.in
+++ b/security/clamav/files/patch-clamav-milter::Makefile.in
@@ -1,14 +1,5 @@
--- clamav-milter/Makefile.in.orig Wed Nov 12 02:36:48 2003
+++ clamav-milter/Makefile.in Fri Nov 21 18:23:35 2003
-@@ -122,7 +122,7 @@
-
- @BUILD_CLAMD_TRUE@@HAVE_MILTER_TRUE@clamav_milter_LDADD = ../clamd/cfgfile.o ../clamd/others.o ../clamscan/getopt.o
-
--@BUILD_CLAMD_TRUE@@HAVE_MILTER_TRUE@man_MANS = ../docs/clamav-milter.8
-+@BUILD_CLAMD_TRUE@@HAVE_MILTER_TRUE@man_MANS = ../docs/man/clamav-milter.8
-
- DEFS = @DEFS@
- # CLAMD_LIBS is used, because clamav-milter requires the same libraries as clamd
@@ -162,7 +162,7 @@
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
CCLD = $(CC)
diff --git a/security/clamav/files/patch-configure b/security/clamav/files/patch-configure
new file mode 100644
index 000000000000..ab505db6d68f
--- /dev/null
+++ b/security/clamav/files/patch-configure
@@ -0,0 +1,28 @@
+--- configure.orig Thu Feb 19 14:18:40 2004
++++ configure Thu Feb 19 14:19:31 2004
+@@ -9317,7 +9317,7 @@
+
+
+
+-if test ! -r "$cfg_dir/clamav.conf"; then
++if true; then
+ INSTALL_CLAMAV_CONF_TRUE=
+ INSTALL_CLAMAV_CONF_FALSE='#'
+ else
+@@ -9327,7 +9327,7 @@
+
+
+
+-if test ! -r "$cfg_dir/freshclam.conf"; then
++if true; then
+ INSTALL_FRESHCLAM_CONF_TRUE=
+ INSTALL_FRESHCLAM_CONF_FALSE='#'
+ else
+@@ -9564,6 +9564,7 @@
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ #include "confdefs.h"
++#include <sys/types.h>
+ #include <netinet/in.h>
+ int main(int argc, char **argv) { in_port_t pt; pt = 0; return pt; }
+ _ACEOF
diff --git a/security/clamav/files/patch-etc::Makefile.in b/security/clamav/files/patch-etc::Makefile.in
new file mode 100644
index 000000000000..d91e60928682
--- /dev/null
+++ b/security/clamav/files/patch-etc::Makefile.in
@@ -0,0 +1,13 @@
+--- etc/Makefile.in.orig Thu Feb 19 14:17:02 2004
++++ etc/Makefile.in Thu Feb 19 14:17:36 2004
+@@ -248,8 +248,8 @@
+
+ install:
+ $(mkinstalldirs) $(DESTDIR)$(CFGINST)
+-@INSTALL_CLAMAV_CONF_TRUE@ @$(INSTALL_DATA) clamav.conf $(DESTDIR)$(CFGINST)
+-@INSTALL_FRESHCLAM_CONF_TRUE@ @$(INSTALL_DATA) freshclam.conf $(DESTDIR)$(CFGINST)
++@INSTALL_CLAMAV_CONF_TRUE@ @$(INSTALL_DATA) clamav.conf $(DESTDIR)$(CFGINST)/clamav.conf.default
++@INSTALL_FRESHCLAM_CONF_TRUE@ @$(INSTALL_DATA) freshclam.conf $(DESTDIR)$(CFGINST)/freshclam.conf.default
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/security/clamav/files/patch-libclamav::message.c b/security/clamav/files/patch-libclamav::message.c
deleted file mode 100644
index eb322ffb1b3e..000000000000
--- a/security/clamav/files/patch-libclamav::message.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- libclamav/message.c.orig Wed Nov 5 11:59:53 2003
-+++ libclamav/message.c Tue Feb 10 14:39:23 2004
-@@ -878,15 +878,20 @@
- if(strcasecmp(line, "end") == 0)
- break;
-
-- assert(strlen(line) <= 62);
- if((line[0] & 0x3F) == ' ')
- break;
-
- len = *line++ - ' ';
-
-- assert((len >= 0) && (len <= 63));
--
-- ptr = decode(line, ptr, uudecode, (len & 3) == 0);
-+ if(len < 0 || len > 63)
-+ /*
-+ * In practice this should never occur since
-+ * the maximum length of a uuencoded line is
-+ * 62 characters
-+ */
-+ cli_warnmsg("uudecode: buffer overflow stopped, attempting to ignore but decoding may fail");
-+ else
-+ ptr = decode(line, ptr, uudecode, (len & 3) == 0);
- break;
-
- case BINARY: