summaryrefslogtreecommitdiff
path: root/security/clamav/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-06-18 09:43:05 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-06-18 09:43:05 +0000
commit15e2ad28454dd207b113f6055df7bec5390ddf9c (patch)
tree46ef06c8cb0b0d8cfa795cf8929859450154e25d /security/clamav/Makefile
parentNew port: games/quake2lnx (diff)
o Add mirror site.
o Remove unnecsesary patches for current. o Add/remove users when installing/removing. o Set permissions on virus database dir. PR: ports/53305 Submitted by: Rob Evers<rob@debank.tv> Approved by: TERAMOTO Masahiro <markun@onohara.to> (maintainer)
Diffstat (limited to 'security/clamav/Makefile')
-rw-r--r--security/clamav/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 93ecbdb71aad..d051d1a3ce56 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -9,7 +9,9 @@ PORTNAME= clamav
PORTVERSION= 0.54
PORTREVISION= 1
CATEGORIES= security
-MASTER_SITES= http://clamav.elektrapro.com/stable/
+MASTER_SITES= http://clamav.elektrapro.com/stable/ \
+ http://clamav.essentkabel.com/stable/
+
MAINTAINER= markun@onohara.to
COMMENT= Command line virus scanner written entirely in C
@@ -36,12 +38,13 @@ MAN8= clamd.8
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500000
-EXTRA_PATCHES= ${FILESDIR}/patch5-*
-.endif
-
pre-install:
- @${ECHO} "==> Creating custom user to run clamav..."
-# ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+ @${ECHO} "===> Creating custom user to run clamav..."
+ ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
+post-install:
+ @${ECHO} "===> Setting permissions..."
+ @${SETENV} PKG_PREFIX=${PREFIX} ${sh} \
+ ${SH} ${PKGINSTALL} ${PREFIX} POST-INSTALL
.include <bsd.port.post.mk>