summaryrefslogtreecommitdiff
path: root/security/bro/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1998-03-02 10:35:04 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1998-03-02 10:35:04 +0000
commit260fc6e9e1b45a6a2916b4c8dca4eed8a61888f9 (patch)
treec77e8bd1cdd443ff70fba4a95f0689652c25c350 /security/bro/Makefile
parentUpgrade to 0.14.0 (diff)
Bro is a system for detecting Network Intruders in real-time by the guys
that brought you tcpdump, libpcap, and flex. Bro is documented in the the USENIX 1998 Security Conference proceedings.
Diffstat (limited to 'security/bro/Makefile')
-rw-r--r--security/bro/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/security/bro/Makefile b/security/bro/Makefile
new file mode 100644
index 000000000000..3de4d8077693
--- /dev/null
+++ b/security/bro/Makefile
@@ -0,0 +1,39 @@
+# ex:ts=8
+# Ports collection makefile for: bro
+# Version required: 0.3alpha
+# Date created: Sat Feb 28, 1998
+# Whom: David O'Brien (obrien@FreeBSD.org)
+#
+# $Id$
+#
+
+DISTNAME= vp-bro-0.3-alpha
+PKGNAME= bro-0.3a
+CATEGORIES= security net
+MASTER_SITES= ftp://ee.lbl.gov/ \
+ ftp://ftp.nuxi.com/pub/misc/
+
+MAINTAINER= obrien@NUXI.com
+
+WRKSRC= ${WRKDIR}/bro-0.3
+CONFIGURE_ARGS+= --libdir=${PREFIX}/share
+GNU_CONFIGURE= yes
+
+post-patch:
+ @${MV} ${WRKSRC}/util.cc ${WRKSRC}/util.cc.in
+ @${SED} -e "s|/usr/src/rtsg/bro/policy:/usr/local/lib/bro|${PREFIX}/share/bro|" \
+ ${WRKSRC}/util.cc.in >${WRKSRC}/util.cc
+pre-install:
+ @${MKDIR} ${PREFIX}/share/bro
+
+post-install:
+ @strip ${PREFIX}/sbin/bro
+ @${INSTALL_DATA} ${WRKSRC}/policy/* ${PREFIX}/share/bro
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/bro
+ ${INSTALL_MAN} ${WRKSRC}/doc/bro-usenix98-revised.ps \
+ ${PREFIX}/share/doc/bro
+ @${GZIP_CMD} ${PREFIX}/share/doc/bro/bro-usenix98-revised.ps
+.endif
+
+.include <bsd.port.mk>