summaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-03-15 10:36:29 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-03-15 10:36:29 +0000
commit8aa1e9d39cb8e6e5599ffa463a7294da7b889a80 (patch)
treec13736a07784189c719c7f69c4952b866cb85a62 /science
parent- Update to 2.6.7 (diff)
Add fastcap , a three-dimensional capacitance extraction program.
PR: ports/93968 Submitted by: Pedro Giffuni <giffunip@asme.org>
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/fastcap/Makefile43
-rw-r--r--science/fastcap/distinfo3
-rw-r--r--science/fastcap/pkg-descr20
-rw-r--r--science/fastcap/pkg-plist46
5 files changed, 113 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 711ce3a61bad..d937a2bbd931 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -18,6 +18,7 @@
SUBDIR += devisor
SUBDIR += dft++
SUBDIR += euler
+ SUBDIR += fastcap
SUBDIR += felt
SUBDIR += flounder
SUBDIR += gave
diff --git a/science/fastcap/Makefile b/science/fastcap/Makefile
new file mode 100644
index 000000000000..7c7839a6ba02
--- /dev/null
+++ b/science/fastcap/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: FastCap
+# Date created: 5 Jan 2006
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fastcap
+DISTVERSION= ${P_VERSION}wr
+CATEGORIES= science cad
+MASTER_SITES= ftp://ftp.srware.com/pub/ \
+ http://www.wrcad.com/ftp/pub/
+
+MAINTAINER= giffunip@asme.org
+COMMENT= A three-dimensional capacitance extraction program
+
+P_VERSION= 2.0
+
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= config
+
+BINFILES= busgen capgen cubegen fastcap pipedgen pyragen
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,TYPE=other,TYPE=4,' \
+ ${WRKSRC}/config
+ @${REINPLACE_CMD} -e 's,CFLAGS =,CFLAGS +=,' \
+ ${WRKSRC}/src/Makefile.4
+
+do-install:
+.for b in ${BINFILES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/${b} ${PREFIX}/bin/
+.endfor
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${CAT} ${WRKSRC}/README ${WRKSRC}/README.mit > ${DOCSDIR}/readme
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.ps ${DOCSDIR}
+ ${GZIP_CMD} ${DOCSDIR}/*
+.endif
+
+.include <bsd.port.mk>
diff --git a/science/fastcap/distinfo b/science/fastcap/distinfo
new file mode 100644
index 000000000000..6e64176c49a9
--- /dev/null
+++ b/science/fastcap/distinfo
@@ -0,0 +1,3 @@
+MD5 (fastcap-2.0wr.tar.gz) = 6cc1f17175d73c5f808e99a0713a7c65
+SHA256 (fastcap-2.0wr.tar.gz) = f47f9f04d1ce750a6e005ffb0ce3dfeb9ef511e930b81bb9f9988fb71a82eb39
+SIZE (fastcap-2.0wr.tar.gz) = 1607118
diff --git a/science/fastcap/pkg-descr b/science/fastcap/pkg-descr
new file mode 100644
index 000000000000..324fd8bfcae3
--- /dev/null
+++ b/science/fastcap/pkg-descr
@@ -0,0 +1,20 @@
+FastCap computes self and mutual capacitances between ideal
+conductors of arbitrary shapes, orientations and sizes.
+The conductors can be embedded in a dielectric region composed
+of any number of constant-permittivity regions of any shape and
+size.
+
+The algorithm used in FastCap is an acceleration of the
+boundary-element technique for solving the integral equation
+associated with the multiple-conductor, multiple-dielectric
+capacitance extraction problem. The linear system resulting
+from the boundary-element discretization is solved using a
+generalized conjugate residual algorithm with a fast multipole
+algorithm to efficiently compute the iterates.
+
+---------------------
+This version of fastcap has been cleaned up and enhanced by Stephen R.
+Whiteley of Whitleley Research Inc.
+---------------------
+
+WWW: http://www.rle.mit.edu/cpg/research_codes.htm
diff --git a/science/fastcap/pkg-plist b/science/fastcap/pkg-plist
new file mode 100644
index 000000000000..1c0163cc027e
--- /dev/null
+++ b/science/fastcap/pkg-plist
@@ -0,0 +1,46 @@
+bin/busgen
+bin/capgen
+bin/cubegen
+bin/fastcap
+bin/pipedgen
+bin/pyragen
+%%EXAMPLESDIR%%/1x1bus.lst
+%%EXAMPLESDIR%%/1x1coarse.neu
+%%EXAMPLESDIR%%/1x1fine.neu
+%%EXAMPLESDIR%%/1x1nonuni.neu
+%%EXAMPLESDIR%%/README
+%%EXAMPLESDIR%%/big_sphere1.neu
+%%EXAMPLESDIR%%/coated_sph.lst
+%%EXAMPLESDIR%%/cond_air_1x1.qui
+%%EXAMPLESDIR%%/cond_dielec_1x1.qui
+%%EXAMPLESDIR%%/connector2.sh
+%%EXAMPLESDIR%%/connector3.sh
+%%EXAMPLESDIR%%/connector4.sh
+%%EXAMPLESDIR%%/cubeeg.fig
+%%EXAMPLESDIR%%/dielec_face.neu
+%%EXAMPLESDIR%%/dielec_sides.neu
+%%EXAMPLESDIR%%/dielec_sides_2x2.neu
+%%EXAMPLESDIR%%/dielec_topbot.neu
+%%EXAMPLESDIR%%/pin
+%%EXAMPLESDIR%%/pipeeg.fig
+%%EXAMPLESDIR%%/ramcell.lst
+%%EXAMPLESDIR%%/ramcell.out
+%%EXAMPLESDIR%%/ramcell_bitl.neu
+%%EXAMPLESDIR%%/ramcell_botd.neu
+%%EXAMPLESDIR%%/ramcell_cond.neu
+%%EXAMPLESDIR%%/ramcell_gnd.neu
+%%EXAMPLESDIR%%/ramcell_test.neu
+%%EXAMPLESDIR%%/ramcell_topd.neu
+%%EXAMPLESDIR%%/ramgen.sh
+%%EXAMPLESDIR%%/sphere1.neu
+%%EXAMPLESDIR%%/sphere2.neu
+%%EXAMPLESDIR%%/sphere3.neu
+%%EXAMPLESDIR%%/testgen.sh
+%%EXAMPLESDIR%%/testrun.sh
+%%EXAMPLESDIR%%/via.neu
+%%PORTDOCS%%%%DOCSDIR%%/mtt.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/tcad.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/ug.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/readme.gz
+@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%