summaryrefslogtreecommitdiff
path: root/science/libctl/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-04-04 07:28:22 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-04-04 07:28:22 +0000
commit665a8725762578548f921fd40a20b2ec433acb2d (patch)
tree173f25b0dc0e3cadf0e7aad46198354d6f539a65 /science/libctl/Makefile
parentUpdate to 2.0.3 and add my autoconfiguration patch which uses DJB's (diff)
add libctl 2.2
Control Language Library
Diffstat (limited to 'science/libctl/Makefile')
-rw-r--r--science/libctl/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/science/libctl/Makefile b/science/libctl/Makefile
new file mode 100644
index 000000000000..3daa80ceb345
--- /dev/null
+++ b/science/libctl/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection Makefile for: libctl
+# Date created: Apr 4, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libctl
+PORTVERSION= 2.2
+CATEGORIES= science math
+MASTER_SITES= http://ab-initio.mit.edu/libctl/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Control Language Library
+
+LIB_DEPENDS= guile.10:${PORTSDIR}/lang/guile
+
+GNU_CONFIGURE= yes
+
+MAN1= gen-ctl-io.1
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/doc/ ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>