summaryrefslogtreecommitdiff
path: root/science/gsystem/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-06-14 12:18:48 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-06-14 12:18:48 +0000
commitba7917858536824c563ad170d0cd77894c76b992 (patch)
tree88db5266cbf35a43f63d0cd180858b9955da7acf /science/gsystem/Makefile
parentUpdate to 2.8.6-p4, should fix port de-install. (diff)
Update to 0.5.1
PR: 82224 Submitted by: Raphael Langerhorst <raphael-langerhorst@gmx.at>
Diffstat (limited to 'science/gsystem/Makefile')
-rw-r--r--science/gsystem/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/science/gsystem/Makefile b/science/gsystem/Makefile
index 2a13f3932883..f776c335a671 100644
--- a/science/gsystem/Makefile
+++ b/science/gsystem/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gsystem
-PORTVERSION= 0.4.1
+PORTVERSION= 0.5.1
CATEGORIES= science devel games
MASTER_SITES= ftp://ftp.g-system.at/pub/gsystem/releases/development/${PORTVERSION}/
DISTNAME= G-System-${PORTVERSION}
@@ -17,7 +17,8 @@ COMMENT= A multi-user virtual reality evolution and life simulation framework
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
USE_BZIP2= yes
-USE_QT_VER= 3
+
+USE_KDELIBS_VER= 3
INSTALLS_SHLIB= yes
NO_FILTER_SHLIBS= yes
@@ -28,7 +29,7 @@ QMAKESPEC= freebsd-g++
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= does not compile with gcc 2.95
+BROKEN= "does not compile with gcc 2.95"
.endif
do-configure:
@@ -41,11 +42,15 @@ do-build:
cd ${WRKSRC}; \
export QTDIR=${QTDIR}; \
export QMAKESPEC=${QMAKESPEC}; \
- ./compile;
+ ./scripts/compile;
do-install:
cd ${WRKSRC}; \
export G_PREFIX=${PREFIX}; \
- ./makeinstall;
+ export G_NO_INST_DOCS=yes; \
+ ./scripts/makeinstall;
+
+post-install:
+ @${CAT} ${PKGMESSAGE};
.include <bsd.port.post.mk>