summaryrefslogtreecommitdiff
path: root/science/gsystem/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-12-28 23:30:00 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-12-28 23:30:00 +0000
commit6fb561edffdc00045f81da812992fe54fa4ba52c (patch)
tree5bf497e64d876cecab4628164de95778dcfb291d /science/gsystem/Makefile
parentWelcome new maintainer! (diff)
Add gsystem, a virtual reality simulation framework, specialised on life and
evolution simulation. I'm a main developer of this framework and I will also keep the FreeBSD port up-to-date, as I'm using FreeBSD as my primary platform. See http://www.g-system.at for details. PR: ports/75466 Submitted by: Raphael Langerhorst <raphael-langerhorst@gmx.at>
Diffstat (limited to 'science/gsystem/Makefile')
-rw-r--r--science/gsystem/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/science/gsystem/Makefile b/science/gsystem/Makefile
new file mode 100644
index 000000000000..2a13f3932883
--- /dev/null
+++ b/science/gsystem/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: G System
+# Date created: 16 December 2004
+# Whom: Raphael Langerhorst <raphael-langerhorst@gmx.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gsystem
+PORTVERSION= 0.4.1
+CATEGORIES= science devel games
+MASTER_SITES= ftp://ftp.g-system.at/pub/gsystem/releases/development/${PORTVERSION}/
+DISTNAME= G-System-${PORTVERSION}
+
+MAINTAINER= raphael-langerhorst@gmx.at
+COMMENT= A multi-user virtual reality evolution and life simulation framework
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+
+USE_BZIP2= yes
+USE_QT_VER= 3
+
+INSTALLS_SHLIB= yes
+NO_FILTER_SHLIBS= yes
+
+QTDIR= ${X11BASE}
+QMAKESPEC= freebsd-g++
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile with gcc 2.95
+.endif
+
+do-configure:
+ cd ${WRKSRC}; \
+ export QTDIR=${QTDIR}; \
+ export QMAKESPEC=${QMAKESPEC}; \
+ qmake;
+
+do-build:
+ cd ${WRKSRC}; \
+ export QTDIR=${QTDIR}; \
+ export QMAKESPEC=${QMAKESPEC}; \
+ ./compile;
+
+do-install:
+ cd ${WRKSRC}; \
+ export G_PREFIX=${PREFIX}; \
+ ./makeinstall;
+
+.include <bsd.port.post.mk>