summaryrefslogtreecommitdiff
path: root/science/fvm
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-06-17 21:04:54 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-06-17 21:04:54 +0000
commit8fecd8a363977c7d53fa001250a32ead0aaf736b (patch)
tree2fc76790cd3db56aa3f887f1c8ff10a761890516 /science/fvm
parentUpdate module useradmin-1.350-1. (diff)
Code_Saturne is EDF's general purpose computational fluid dynamics
software. Developed since 1997 at EDF R&D, it is based on a co-located Finite Volume approach that accepts meshes with any type of cell (tetrahedral, hexahedral, prismatic, pyramidal, polyhedral, ...) and any type of grid structure (unstructured, blockstructured, hybrid, conforming or with hanging nodes, ...). Its basic capabilities enable the handling of either incompressible or expandable flows with or without heat transfer and turbulence (mixing length, 2-equation models, v2f, Reynolds stress models, Large Eddy Simulations, ...). <http://rd.edf.com/code_saturne/>
Diffstat (limited to 'science/fvm')
-rw-r--r--science/fvm/Makefile54
-rw-r--r--science/fvm/distinfo3
-rw-r--r--science/fvm/files/patch-configure74
-rw-r--r--science/fvm/pkg-descr5
-rw-r--r--science/fvm/pkg-plist23
5 files changed, 159 insertions, 0 deletions
diff --git a/science/fvm/Makefile b/science/fvm/Makefile
new file mode 100644
index 000000000000..997d33eae180
--- /dev/null
+++ b/science/fvm/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: fvm
+# Date created: Sun 1 apr 2007
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= fvm
+PORTVERSION= 0.6.3
+CATEGORIES= science parallel
+MASTER_SITES= http://www.edf.fr/html/RetD/livraison_saturne_${REL_DATE}/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Code_Saturne Finite Volume Mesh
+
+LIB_DEPENDS= med.2:${PORTSDIR}/french/med \
+ bft.1:${PORTSDIR}/science/bft \
+ hdf5.0:${PORTSDIR}/science/hdf5 \
+ cgns.0:${PORTSDIR}/science/cgnslib
+
+REL_DATE= 070305
+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-bft-prefix=${LOCALBASE} \
+ --with-hdf5-prefix=${LOCALBASE} \
+ --with-cgns-prefix=${LOCALBASE} \
+ --with-med-prefix=${LOCALBASE}
+CONFIGURE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
+
+.if defined(WITH_LAM)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/liblam.a:${PORTSDIR}/net/lam
+RUN_DEPENDS+= ${LOCALBASE}/bin/lamboot:${PORTSDIR}/net/lam
+CONFIGURE_ARGS+= --with-mpi-prefix=${LOCALBASE}
+.elif defined(WITH_OPENMPI)
+BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
+RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
+CONFIGURE_ARGS+= --with-mpi-prefix=${LOCALBASE}/mpi/openmpi
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpirun:${PORTSDIR}/net/mpich2
+CONFIGURE_ARGS+= --with-mpi-prefix=${LOCALBASE}/mpich2
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+pre-configure:
+ # No useful doc there
+ ${REINPLACE_CMD} -e 's|tests doc|tests|' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/science/fvm/distinfo b/science/fvm/distinfo
new file mode 100644
index 000000000000..d86bbb5e77da
--- /dev/null
+++ b/science/fvm/distinfo
@@ -0,0 +1,3 @@
+MD5 (fvm-0.6.3.tar.gz) = f02b468bb9677809305d160b41b8f949
+SHA256 (fvm-0.6.3.tar.gz) = 1566ff22213846f24d976ef11a9e1e9aef485f870206656ab301f899bc5bdcbb
+SIZE (fvm-0.6.3.tar.gz) = 566676
diff --git a/science/fvm/files/patch-configure b/science/fvm/files/patch-configure
new file mode 100644
index 000000000000..758f79ea0227
--- /dev/null
+++ b/science/fvm/files/patch-configure
@@ -0,0 +1,74 @@
+--- configure.orig Thu Feb 15 18:57:25 2007
++++ configure Fri May 4 23:03:56 2007
+@@ -19654,7 +19654,7 @@
+ HDF5_CPPFLAGS="-I$with_hdf5_prefix/include"
+ HDF5_LDFLAGS="-L$with_hdf5_prefix/lib"
+ fi
+- HDF5_LIBS="-lhdf5"
++ HDF5_LIBS="-lhdf5 $PTHREAD_LIBS"
+
+ CPPFLAGS="${CPPFLAGS} ${HDF5_CPPFLAGS}"
+ LDFLAGS="${LDFLAGS} ${HDF5_LDFLAGS}"
+@@ -19666,7 +19666,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lhdf5 $LIBS"
++LIBS="$HDF5_LIBS $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -19810,7 +19810,7 @@
+ elif test "x$with_cgns_prefix" != "x" ; then
+ CGNS_LDFLAGS="-L$with_cgns_prefix/lib"
+ fi
+- CGNS_LIBS="-lcgns"
++ CGNS_LIBS="-lcgns $HDF5_LIBS"
+ CPPFLAGS="${CPPFLAGS} ${CGNS_CPPFLAGS}"
+ LDFLAGS="${LDFLAGS} ${CGNS_LDFLAGS}"
+ LIBS="${LIBS} ${CGNS_LIBS}"
+@@ -19821,7 +19821,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lcgns $LIBS"
++LIBS="$CGNS_LIBS $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -20810,6 +20810,8 @@
+ fi
+ fi;
+ MED_LIBS="-lmedC -lpthread";;
++ freebsd*)
++ MED_ARCH_NAME=FREEBSD;;
+ osf*)
+ if test "x$ints_are_64bit" != "xyes" ; then
+ MED_ARCH_NAME=OSF1_32
+@@ -25366,7 +25368,7 @@
+ { echo "$as_me:$LINENO: checking for MPI (basic test)" >&5
+ echo $ECHO_N "checking for MPI (basic test)... $ECHO_C" >&6; }
+ if test "$MPI_LIBS" = "" ; then
+- MPI_LIBS="-lmpi"
++ MPI_LIBS="-lmpi $PTHREAD_LIBS"
+ fi
+ CPPFLAGS="$saved_CPPFLAGS $MPI_CPPFLAGS"
+ LDFLAGS="$saved_LDFLAGS $MPI_LDFLAGS"
+@@ -25422,7 +25424,7 @@
+ { echo "$as_me:$LINENO: checking for MPI (mpich test)" >&5
+ echo $ECHO_N "checking for MPI (mpich test)... $ECHO_C" >&6; }
+ # First try (simplest)
+- MPI_LIBS="-lmpich"
++ MPI_LIBS="-lmpich $PTHREAD_LIBS"
+ LIBS="$saved_LIBS $MPI_LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+@@ -25524,7 +25526,7 @@
+ { echo "$as_me:$LINENO: checking for MPI (lam-mpi test)" >&5
+ echo $ECHO_N "checking for MPI (lam-mpi test)... $ECHO_C" >&6; }
+ # First try (without MPI-IO)
+- MPI_LIBS="-lmpi -llam -lpthread"
++ MPI_LIBS="-lmpi -llam $PTHREAD_LIBS"
+ LIBS="$saved_LIBS $MPI_LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
diff --git a/science/fvm/pkg-descr b/science/fvm/pkg-descr
new file mode 100644
index 000000000000..6787774c7ab1
--- /dev/null
+++ b/science/fvm/pkg-descr
@@ -0,0 +1,5 @@
+BFT stands for Finite Volume Mesh.
+It is intended to provide finite volume mesh I/O and some other services such
+as interpolation, possibly in parallel using MPI.
+
+WWW: http://rd.edf.com/code_saturne/
diff --git a/science/fvm/pkg-plist b/science/fvm/pkg-plist
new file mode 100644
index 000000000000..65dab748c27d
--- /dev/null
+++ b/science/fvm/pkg-plist
@@ -0,0 +1,23 @@
+bin/fvm-config
+include/fvm_config.h
+include/fvm_config_priv.h
+include/fvm_defs.h
+include/fvm_interface.h
+include/fvm_io_num.h
+include/fvm_locator.h
+include/fvm_nodal.h
+include/fvm_nodal_append.h
+include/fvm_nodal_extract.h
+include/fvm_nodal_extrude.h
+include/fvm_nodal_from_desc.h
+include/fvm_nodal_order.h
+include/fvm_nodal_project.h
+include/fvm_nodal_triangulate.h
+include/fvm_order.h
+include/fvm_parall.h
+include/fvm_triangulate.h
+include/fvm_writer.h
+lib/libfvm.a
+lib/libfvm.la
+lib/libfvm.so
+lib/libfvm.so.0