summaryrefslogtreecommitdiff
path: root/science/chemtool-devel
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2005-11-20 02:49:30 +0000
committerMaho Nakata <maho@FreeBSD.org>2005-11-20 02:49:30 +0000
commita9c05e1b1bdbed4b1f86cb4f289fcc007f795255 (patch)
tree7624caa181f9baeb463cc8e8d3bb41e1b9cdcc0a /science/chemtool-devel
parentUpgrade to 6.2.1. Mostly a bugfix release. (diff)
Update to 1.7alpha15
Diffstat (limited to 'science/chemtool-devel')
-rw-r--r--science/chemtool-devel/Makefile21
-rw-r--r--science/chemtool-devel/distinfo3
-rw-r--r--science/chemtool-devel/files/patch-Makefile.in20
-rw-r--r--science/chemtool-devel/files/patch-configure22
-rw-r--r--science/chemtool-devel/pkg-plist26
5 files changed, 51 insertions, 41 deletions
diff --git a/science/chemtool-devel/Makefile b/science/chemtool-devel/Makefile
index c25e638c0d8d..e46d3709a863 100644
--- a/science/chemtool-devel/Makefile
+++ b/science/chemtool-devel/Makefile
@@ -5,14 +5,11 @@
# $FreeBSD$
PORTNAME= chemtool
-PORTVERSION= 1.6.1
-PORTREVISION= 1
+PORTVERSION= 1.7.20050716
CATEGORIES= science
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-# http://ruby.chemie.uni-freiburg.de/~martin/chemtool/
-MASTER_SITE_SUBDIR= maho/chemtool
+MASTER_SITES= http://ruby.chemie.uni-freiburg.de/~martin/chemtool/
-DISTNAME= ct161gtk2
+DISTNAME= ct17a15
EXTRACT_SUFX= .tgz
MAINTAINER= maho@FreeBSD.org
@@ -21,18 +18,22 @@ COMMENT= Drawing organic molecules easily and store them (developer version)
LIB_DEPENDS= EMF.1:${PORTSDIR}/graphics/libemf
RUN_DEPENDS= transfig:${PORTSDIR}/print/transfig
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-gtk2/
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.7alpha15/
USE_REINPLACE= yes
-USE_GNOME= gtk12
-USE_AUTOTOOLS= autoconf:213
+USE_GNOME= gtk20
+#USE_AUTOTOOLS= autoconf:213
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS= --enable-emf=yes
PKGNAMESUFFIX= -devel
MAN1= chemtool.1 cht.1
+#to include emf
+CFLAGS+= -I${LOCALBASE}/include/libEMF
+CXXFLAGS+= -I${LOCALBASE}/include/libEMF
post-patch:
- ${REINPLACE_CMD} -e 's+%%LOCALBASE%%+${LOCALBASE}+g;' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's+%%LOCALBASE%%+${LOCALBASE}+g;' ${WRKSRC}/configure.in
+ @${REINPLACE_CMD} -e 's+%%LOCALBASE%%+${LOCALBASE}+g;' ${WRKSRC}/configure
do-install:
@(cd ${WRKSRC}; ${GMAKE} install)
diff --git a/science/chemtool-devel/distinfo b/science/chemtool-devel/distinfo
index e23eaa29619b..984ce2d57a05 100644
--- a/science/chemtool-devel/distinfo
+++ b/science/chemtool-devel/distinfo
@@ -1 +1,2 @@
-MD5 (ct161gtk2.tgz) = 8f2c8b74dffee3021d5c24cc61372e90
+MD5 (ct17a15.tgz) = 5e49dd9715196ba5616686f365f50ef8
+SIZE (ct17a15.tgz) = 445473
diff --git a/science/chemtool-devel/files/patch-Makefile.in b/science/chemtool-devel/files/patch-Makefile.in
deleted file mode 100644
index 192144e2a79d..000000000000
--- a/science/chemtool-devel/files/patch-Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.in.orig Thu Aug 28 07:25:31 2003
-+++ Makefile.in Sat Oct 4 11:16:42 2003
-@@ -5,7 +5,7 @@
- mandir=@mandir@
- kdedir=@kdemimedir@
- gnomedir=@gnomemimedir@
--CFLAGS=-O2 -Wall -Wunused -Wuninitialized -I. `gtk-config --cflags` @DEFS@ -DLOCALEDIR=\"${localedir}\"
-+CFLAGS= @CFLAGS@ -I%%LOCALBASE%%/include -I%%LOCALBASE%%/include/libEMF -I. `gtk-config --cflags` @DEFS@ -DLOCALEDIR=\"${localedir}\"
-
- CC=@CC@
- CP=/bin/cp
-@@ -16,7 +16,7 @@
- SRCS = main.c chemproc.c graph.c draw.c inout.c undo.c @MYGTKSRCS@
- OBJS = main.o chemproc.o graph.o draw.o inout.o undo.o @MYGTKOBJS@
-
--SYS_LIBRARIES = `gtk-config --libs` @EMFLIBS@ -lm
-+SYS_LIBRARIES = `gtk-config --libs` -L%%LOCALBASE%%/lib @EMFLIBS@ -lm
-
-
- all: chemtool cht
diff --git a/science/chemtool-devel/files/patch-configure b/science/chemtool-devel/files/patch-configure
new file mode 100644
index 000000000000..d2721910d5fb
--- /dev/null
+++ b/science/chemtool-devel/files/patch-configure
@@ -0,0 +1,22 @@
+--- configure.in~ Sun Jul 17 01:15:14 2005
++++ configure.in Sun Nov 20 11:30:35 2005
+@@ -252,7 +252,7 @@
+ if test x$enable_emf = xyes; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(EMF)
+- EMFLIBS="-lEMF -lstdc++"
++ EMFLIBS="-L%%LOCALBASE%%/lib -lEMF -lstdc++"
+ else
+ AC_MSG_RESULT(no)
+ EMFLIBS=""
+--- configure~ Sun Nov 20 11:29:37 2005
++++ configure Sun Nov 20 11:31:32 2005
+@@ -2859,7 +2859,7 @@
+ #define EMF 1
+ EOF
+
+- EMFLIBS="-lEMF -lstdc++"
++ EMFLIBS="-L%%LOCALBASE%%/lib -lEMF -lstdc++"
+ else
+ echo "$ac_t""no" 1>&6
+ EMFLIBS=""
diff --git a/science/chemtool-devel/pkg-plist b/science/chemtool-devel/pkg-plist
index 899c54053277..350ca7060ff4 100644
--- a/science/chemtool-devel/pkg-plist
+++ b/science/chemtool-devel/pkg-plist
@@ -9,35 +9,41 @@ share/examples/chemtool/Indolizomycin.cht
share/examples/chemtool/Lepicidin-A-Aglycon.cht
share/examples/chemtool/Neu2
share/examples/chemtool/amine.mol
-share/examples/chemtool/anabsinthin
-share/examples/chemtool/atp
+share/examples/chemtool/anabsinthin.cht
+share/examples/chemtool/anthocyanidine.cht
+share/examples/chemtool/atp.cht
share/examples/chemtool/bcarotin.pdb
share/examples/chemtool/breve.cht
share/examples/chemtool/breve.mol
-share/examples/chemtool/bufotalin
+share/examples/chemtool/breve_frag.cht
+share/examples/chemtool/breve_frag.mol
+share/examples/chemtool/bufotalin.cht
share/examples/chemtool/byrostatin1.cht
share/examples/chemtool/c70.cht
-share/examples/chemtool/camphor
-share/examples/chemtool/chlorophyll
+share/examples/chemtool/camphor.cht
+share/examples/chemtool/chlorophyll.cht
share/examples/chemtool/claisen.cht
share/examples/chemtool/dodecahedran.cht
-share/examples/chemtool/indigo
-share/examples/chemtool/kdo
+share/examples/chemtool/indigo.cht
+share/examples/chemtool/kdo.cht
share/examples/chemtool/krebs.cht
share/examples/chemtool/labeltest
share/examples/chemtool/pagodan.cht
share/examples/chemtool/penicillin_v.cht
-share/examples/chemtool/pteridin
+share/examples/chemtool/pteridin.cht
share/examples/chemtool/reaction.cht
share/examples/chemtool/rutamycin_b.cht
-share/examples/chemtool/tbutylazulene
+share/examples/chemtool/sample.sdf
+share/examples/chemtool/tbutylazulene.cht
share/examples/chemtool/tcdd.cht
-share/examples/chemtool/tetracyclin
+share/examples/chemtool/tetracyclin.cht
+share/examples/chemtool/v3000.mol
share/examples/chemtool/viagra.cht
@dirrm share/examples/chemtool
share/locale/cs/LC_MESSAGES/chemtool.mo
share/locale/de/LC_MESSAGES/chemtool.mo
share/locale/fr/LC_MESSAGES/chemtool.mo
+share/locale/nl/LC_MESSAGES/chemtool.mo
share/locale/pl/LC_MESSAGES/chemtool.mo
share/locale/pt_BR/LC_MESSAGES/chemtool.mo
share/locale/ru/LC_MESSAGES/chemtool.mo