summaryrefslogtreecommitdiff
path: root/print/ktexshell/Makefile
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2001-03-28 09:50:40 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2001-03-28 09:50:40 +0000
commit378988c9ad0b34e0f431df6b3a2534c2df32c36a (patch)
treed5d2843ca1dc3a918b026b97786e879dd11a025b /print/ktexshell/Makefile
parentAdd panda, a GPL'ed PDF generation library. (diff)
New port: ktexshell.
KDE frontend to the popular TeX/LaTeX typesetting system
Diffstat (limited to 'print/ktexshell/Makefile')
-rw-r--r--print/ktexshell/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/print/ktexshell/Makefile b/print/ktexshell/Makefile
new file mode 100644
index 000000000000..2ec63d61ec5a
--- /dev/null
+++ b/print/ktexshell/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: ktexshell
+# Date created: 28 March 2001
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ktexshell
+PORTVERSION= 0.4.0
+CATEGORIES= print kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ktexshell
+
+MAINTAINER= demon@FreeBSD.org
+
+LIB_DEPENDS= kdecore.4:${PORTSDIR}/x11/kdelibs2 \
+ intl.1:${PORTSDIR}/devel/gettext
+
+USE_QT2= yes
+MOC?= ${X11BASE}/bin/moc2
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
+ --with-qt-libraries=${X11BASE}/lib \
+ --with-extra-libs=${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include" \
+ MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
+ LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
+
+post-patch:
+ @${PERL} -pi -e 's#libqt#libqt2#g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's#lqt#lqt2#g' ${WRKSRC}/configure ${WRKSRC}/ktexshell/Makefile.in
+
+.include <bsd.port.mk>