summaryrefslogtreecommitdiff
path: root/print/foomatic-db-engine
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-10-12 12:16:21 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-10-12 12:16:21 +0000
commit23799d8de427a4d39736a4f3e889ce2d4f1a73a7 (patch)
tree01fbae044b94aa77152fa696c2b17f5136cf2394 /print/foomatic-db-engine
parentColor::Rgb - simple rgb.txt parsing class. (diff)
Update to version 3.0.2
PR: ports/72325 Submitted by: Ports Fury
Diffstat (limited to 'print/foomatic-db-engine')
-rw-r--r--print/foomatic-db-engine/Makefile72
-rw-r--r--print/foomatic-db-engine/distinfo3
-rw-r--r--print/foomatic-db-engine/files/patch-Makefile.in29
-rw-r--r--print/foomatic-db-engine/files/patch-configure.in15
-rw-r--r--print/foomatic-db-engine/files/patch-make_configure10
-rw-r--r--print/foomatic-db-engine/pkg-plist5
6 files changed, 25 insertions, 109 deletions
diff --git a/print/foomatic-db-engine/Makefile b/print/foomatic-db-engine/Makefile
index 41b730b4e93a..a50c26b329e7 100644
--- a/print/foomatic-db-engine/Makefile
+++ b/print/foomatic-db-engine/Makefile
@@ -6,35 +6,24 @@
#
PORTNAME= foomatic-db-engine
-PORTVERSION= 20031213
-PORTREVISION= 2
+PORTVERSION= 3.0.2
+PORTEPOCH= 1
CATEGORIES= print
-MASTER_SITES= #
+MASTER_SITES= http://www.linuxprinting.org/download/foomatic/%SUBDIR%/
+MASTER_SITE_SUBDIR= . oldstuff
MAINTAINER= ports@FreeBSD.org
COMMENT= Foomatic database engine
-LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
- curl.3:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= curl:${PORTSDIR}/ftp/curl
+RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl
-BROKEN= "Configure fails"
-
-USE_GMAKE= yes
+USE_GNOME= libxml2
USE_PERL5= yes
-USE_BZIP2= yes
-WANT_AUTOMAKE_VER= 15
-USE_AUTOCONF_VER= 253
+USE_GMAKE= yes
GNU_CONFIGURE= yes
-NO_CHECKSUM= yes # the tarball is created on the fly from CVS
-CONFIGURE_ARGS= --prefix=${PREFIX}
CONFIGURE_ENV= PERL=${PERL} LIBDIR=${PREFIX}/share/foomatic/
-.include <bsd.port.pre.mk>
-CVS_CMD?= cvs -z3
-CVS_DATE= ${PORTVERSION}
-CVS_SITES?= pserver:anonymous@cvs.linuxprinting.org:/usr/local/cvs
-CVS_MODULE= foomatic-db-engine
-
MAN1= foomatic-printjob.1 foomatic-ppdfile.1 foomatic-perl-data.1 \
foomatic-configure.1 foomatic-compiledb.1 foomatic-combo-xml.1 \
foomatic-ppd-options.1
@@ -42,39 +31,16 @@ MAN8= foomatic-preferred-driver.8 \
foomatic-kitload.8 foomatic-getpjloptions.8 \
foomatic-addpjloptions.8
-#
-# CVS checkout stuff mostly stolen from security/openssh-askpass port by
-# kris@freebsd.org
-#
-do-fetch:
- @if test ! -f ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ; then \
- ${MKDIR} ${DISTDIR}/${DISTNAME} && \
- cd ${DISTDIR}/${DISTNAME}; \
- for CVS_SITE in ${CVS_SITES}; do \
- ${ECHO_MSG} ">> Attempting to check out from $${CVS_SITE}."; \
- if ${CVS_CMD} -d:$${CVS_SITE} co -D "${CVS_DATE}" ${CVS_MODULE}; \
- then \
- cd ${DISTDIR}; \
- ${ECHO_MSG} ">> Creating dist tarball in ${DISTDIR}"; \
- ${ECHO_MSG} ">> \"${DISTNAME}${EXTRACT_SUFX}\"."; \
- ${MV} ${DISTNAME}/${CVS_MODULE} \
- ${DISTNAME}/${CVS_MODULE:H}/${DISTNAME}; \
- ${TAR} -cj \
- -f ${DISTNAME}${EXTRACT_SUFX} \
- -C ${DISTNAME}/${CVS_MODULE:H} \
- ${DISTNAME}; \
- exit; \
- fi \
- done; \
- ${RMDIR} ${DISTDIR}/${DISTNAME}; \
- ${ECHO_MSG} ">> CVS checkout failed."; \
- exit 1; \
- fi
-
-#pre-configure:
-# @cd ${WRKSRC} && ${SETENV} ${SCRIPTS_ENV} ./make_configure
+post-patch:
+ @${PERL} -pi.bak -e \
+ "s,sysconfdir=/etc,sysconfdir=\'${PREFIX}/etc\',g ; \
+ s,/usr/local/etc:,${PREFIX}/etc:,g" ${WRKSRC}/configure
+ @${PERL} -pi.bak -e \
+ "s,/usr/local/bin:,${PREFIX}/bin:,g" ${WRKSRC}/Makefile.in
-post-build:
- @${CHMOD} +x ${WRKSRC}/mkinstalldirs
+post-install:
+.for file in foomatic-combo-xml foomatic-perl-data
+ @${STRIP_CMD} ${PREFIX}/bin/${file}
+.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/foomatic-db-engine/distinfo b/print/foomatic-db-engine/distinfo
index 909a246d04e3..a67101307b0c 100644
--- a/print/foomatic-db-engine/distinfo
+++ b/print/foomatic-db-engine/distinfo
@@ -1 +1,2 @@
-Data is retrieved via CVS
+MD5 (foomatic-db-engine-3.0.2.tar.gz) = 3061b8d3f7870467e6fbeae8d4399211
+SIZE (foomatic-db-engine-3.0.2.tar.gz) = 286367
diff --git a/print/foomatic-db-engine/files/patch-Makefile.in b/print/foomatic-db-engine/files/patch-Makefile.in
deleted file mode 100644
index 3eb17b7ba9e6..000000000000
--- a/print/foomatic-db-engine/files/patch-Makefile.in
+++ /dev/null
@@ -1,29 +0,0 @@
---- Makefile.in.orig Thu Nov 20 21:08:05 2003
-+++ Makefile.in Wed Jul 7 16:27:06 2004
-@@ -53,7 +53,7 @@
- ## C settings
- CC=@CC@
- CFLAGS=@CFLAGS@
--XML_CFLAGS=@XML_CFLAGS@
-+XML_CPPFLAGS=@XML_CPPFLAGS@
- XML_LIBS=@XML_LIBS@
-
- ## Settings for Perl
-@@ -64,7 +64,7 @@
- PERL_INSTALLDIRS=@PERL_INSTALLDIRS@
-
- # Genereal paths for all filter scripts
--EXEC_PATH=/usr/local/bin:/usr/bin:/bin
-+EXEC_PATH=${LOCALBASE}/bin:/usr/bin:/bin
- LOG_PATH=/tmp
-
- # Paths for LPD and LPRng
-@@ -221,7 +221,7 @@
- $(CC) $(CFLAGS) -o foomatic-combo-xml foomatic-combo-xml.c
-
- foomatic-perl-data: foomatic-perl-data.c
-- $(CC) $(CFLAGS) $(XML_CFLAGS) $(XML_LIBS) -o foomatic-perl-data foomatic-perl-data.c
-+ $(CC) $(CFLAGS) $(XML_CPPFLAGS) $(XML_LIBS) -o foomatic-perl-data foomatic-perl-data.c
-
- man:
- chmod a+rx ./makeMan
diff --git a/print/foomatic-db-engine/files/patch-configure.in b/print/foomatic-db-engine/files/patch-configure.in
deleted file mode 100644
index 16899c80d9bb..000000000000
--- a/print/foomatic-db-engine/files/patch-configure.in
+++ /dev/null
@@ -1,15 +0,0 @@
---- configure.in.orig Wed Jul 7 05:46:16 2004
-+++ configure.in Wed Jul 7 05:45:39 2004
-@@ -18,9 +18,9 @@
- dnl LIBS="$LIBS"
-
- AM_PATH_XML2(2.0.0)
--if test ! -n "$XML_LIBS" ; then
-- AM_PATH_XML(1.8.17)
--fi
-+dnl if test ! -n "$XML_LIBS" ; then
-+dnl AM_PATH_XML(1.8.17)
-+dnl fi
- dnl CFLAGS="$CFLAGS $XML_CFLAGS"
- dnl LIBS="$LIBS $XML_LIBS"
-
diff --git a/print/foomatic-db-engine/files/patch-make_configure b/print/foomatic-db-engine/files/patch-make_configure
deleted file mode 100644
index 33e4892ac865..000000000000
--- a/print/foomatic-db-engine/files/patch-make_configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- make_configure.orig Fri Oct 11 01:16:34 2002
-+++ make_configure Wed Jul 7 18:23:05 2004
-@@ -1,3 +1,3 @@
--aclocal
--autoconf
--perl -p -i -e "s=\#include <xmlversion.h>=\#include <libxml/xmlversion.h>=g" configure
-\ No newline at end of file
-+aclocal15
-+autoconf253
-+perl -p -i -e "s=\#include <xmlversion.h>=\#include <libxml/xmlversion.h>=g" configure
diff --git a/print/foomatic-db-engine/pkg-plist b/print/foomatic-db-engine/pkg-plist
index 7548117ac4cc..944f9b22b283 100644
--- a/print/foomatic-db-engine/pkg-plist
+++ b/print/foomatic-db-engine/pkg-plist
@@ -17,6 +17,7 @@ sbin/foomatic-getpjloptions
sbin/foomatic-kitload
sbin/foomatic-nonumericalids
sbin/foomatic-preferred-driver
+sbin/foomatic-printermap-to-gimp-print-xml
sbin/foomatic-replaceoldprinterids
share/foomatic/templates/pjl_enum_choice.xml
share/foomatic/templates/pjl_enum_option.xml
@@ -24,4 +25,6 @@ share/foomatic/templates/pjl_num_option.xml
@dirrm %%SITE_PERL%%/Foomatic
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Foomatic
@dirrm share/foomatic/templates
-@dirrm share/foomatic
+@unexec rmdir %D/share/foomatic 2>/dev/null || true
+@unexec rmdir %D/etc/foomatic
+@exec mkdir -p %D/etc/foomatic