summaryrefslogtreecommitdiff
path: root/print/cups-pstoraster/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-11-26 21:05:46 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-11-26 21:05:46 +0000
commit1601298e7a21ac8680af3159bf8bcb35b5909b25 (patch)
treeb654b585037cd89efe5b80d4f0b6fc367a616bed /print/cups-pstoraster/Makefile
parent- Update to 1.2.1 (diff)
Add "pstopxl" filter
Support PLIST_FILES PR: ports/74427 Submitted by: Ports Fury
Diffstat (limited to 'print/cups-pstoraster/Makefile')
-rw-r--r--print/cups-pstoraster/Makefile27
1 files changed, 18 insertions, 9 deletions
diff --git a/print/cups-pstoraster/Makefile b/print/cups-pstoraster/Makefile
index a0fcaf697cc8..1aa2b6a51c24 100644
--- a/print/cups-pstoraster/Makefile
+++ b/print/cups-pstoraster/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cups-pstoraster
PORTVERSION= 7.07
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.easysw.com/pub/ghostscript/
@@ -31,21 +31,27 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --without-x --without-ijs --without-gimp-print \
--with-gs=espgs
MAKE_ARGS= CFLAGS_STANDARD="${CFLAGS} -DUPD_SIGNAL=0" \
- DEVICE_DEVS="\$$(DD)cups.dev"
+ DEVICE_DEVS="\$$(DD)cups.dev \$$(DD)pxlcolor.dev \$$(DD)pxlmono.dev"
+
+PLIST_FILES= bin/espgs etc/cups/pstoraster.convs \
+ libexec/cups/filter/pstopxl libexec/cups/filter/pstoraster \
+ share/cups/model/pxlcolor.ppd share/cups/model/pxlmono.ppd
post-patch:
${LN} -sf ${ESPGS_WRKSRC}/gdevcups.c ${WRKSRC}/src
${CAT} ${FILESDIR}/cups.contrib.mak >> ${WRKSRC}/src/contrib.mak
+.for file in pstopxl pstoraster
${SED} -e 's:@prefix@:${PREFIX}:g ; \
s:@exec_prefix@:${PREFIX}:g ; \
s:@bindir@:${PREFIX}/bin:g ; \
s:@GS@:espgs:g' \
- ${ESPGS_WRKSRC}/pstoraster.in > ${ESPGS_WRKSRC}/pstoraster
+ ${ESPGS_WRKSRC}/${file}.in > ${ESPGS_WRKSRC}/${file}
+.endfor
${REINPLACE_CMD} -e 's|^CFLAGS=|CFLAGS=@CPPFLAGS@ |g ; \
s|^LDFLAGS=|LDFLAGS=@LDFLAGS@ |g ; \
s|^DEVICE_DEVS|#DEVICE_DEVS|g' ${WRKSRC}/Makefile.in
@@ -56,12 +62,15 @@ pre-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/espgs ${PREFIX}/bin
- ${INSTALL_DATA} ${ESPGS_WRKSRC}/pstoraster.convs \
- ${PREFIX}/etc/cups
- ${INSTALL_SCRIPT} ${ESPGS_WRKSRC}/pstoraster \
- ${PREFIX}/libexec/cups/filter
+ ${INSTALL_DATA} ${ESPGS_WRKSRC}/pstoraster.convs ${PREFIX}/etc/cups
+.for file in pstopxl pstoraster
+ ${INSTALL_SCRIPT} ${ESPGS_WRKSRC}/${file} ${PREFIX}/libexec/cups/filter
+.endfor
${CHOWN} -R ${CUPSOWN}:${CUPSGRP} \
${PREFIX}/etc/cups ${PREFIX}/libexec/cups/filter
+.for file in pxlcolor.ppd pxlmono.ppd
+ ${INSTALL_DATA} ${ESPGS_WRKSRC}/${file} ${PREFIX}/share/cups/model
+.endfor
.include "${.CURDIR}/../../print/cups/Makefile.common"
.include <bsd.port.pre.mk>