summaryrefslogtreecommitdiff
path: root/ports-mgmt/portupgrade-devel/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-10-29 22:18:30 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-10-29 22:18:30 +0000
commitb890a420cd3b590acc73ec5996e2a7f8ce4ed7ed (patch)
tree27b7993ee158c9a6b916bec72fa64ef3a6cfa685 /ports-mgmt/portupgrade-devel/Makefile
parentAdd a patch, which, according to the submitter, allows to compile (diff)
Update to 20011030. Some minor bugs/typos were fixed.
portupgrade: - Fix quotes. [Submitted by: Jimmy Olgeni <olgeni@uli.it>] - Do not ask whether to install a port twice. (portinstall/-N) - Complete missing words in the manpage. pkgdb: - Comment out deleted pkgdeps properly. misc.: - Convert the install script to Makefiles. - Change the examples/docs subdirectory name from `portupgrade' to `pkgtools'.
Diffstat (limited to 'ports-mgmt/portupgrade-devel/Makefile')
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile37
1 files changed, 15 insertions, 22 deletions
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index 852e5aa12f13..b387b3cd59e2 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= portupgrade
-PORTVERSION= 20011029.1
+PORTVERSION= 20011030
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://www.iDaemons.org/distfiles/
@@ -25,17 +25,17 @@ RUN_DEPENDS= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/devel/ruby-optparse \
USE_RUBY= yes
-RUBY_SHEBANG_FILES= \
- ${WRKSRC}/pkg_fetch \
- ${WRKSRC}/pkg_glob \
- ${WRKSRC}/pkgdb \
- ${WRKSRC}/portcvsweb \
- ${WRKSRC}/portsclean \
- ${WRKSRC}/portsdb \
- ${WRKSRC}/portupgrade \
- ${WRKSRC}/portversion
+MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
-NO_BUILD= yes
+RUBY_SHEBANG_FILES= \
+ ${WRKSRC}/bin/pkg_fetch \
+ ${WRKSRC}/bin/pkg_glob \
+ ${WRKSRC}/bin/pkgdb \
+ ${WRKSRC}/bin/portcvsweb \
+ ${WRKSRC}/bin/portsclean \
+ ${WRKSRC}/bin/portsdb \
+ ${WRKSRC}/bin/portupgrade \
+ ${WRKSRC}/bin/portversion
MAN1= pkg_deinstall.1 \
pkg_fetch.1 \
@@ -49,25 +49,18 @@ MAN1= pkg_deinstall.1 \
MLINKS= pkgdb.1 pkg_which.1 \
portupgrade.1 portinstall.1 \
portsdb.1 ports_glob.1
-MANCOMPRESSED= yes
+MANCOMPRESSED= maybe
DOCS= ChangeLog README
-EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/pkgtools
post-patch:
.for f in pkgdb.rb pkgtools.rb
- ${RUBY} -i~ -pe 'sub %r:/usr/local:, "${LOCALBASE}"' ${WRKSRC}/${f}
+ ${RUBY} -i~ -pe 'sub %r:/usr/local:, "${LOCALBASE}"' ${WRKSRC}/lib/${f}
.endfor
-do-install:
- cd ${WRKSRC} && ${RUBY} install.rb
- ${MKDIR} ${PREFIX}/share/zsh/site-functions
- ${INSTALL_DATA} ${WRKSRC}/misc/zsh/* ${PREFIX}/share/zsh/site-functions/
- ${MKDIR} ${EXAMPLESDIR}/bash
- ${INSTALL_DATA} ${WRKSRC}/misc/bash/* ${EXAMPLESDIR}/bash/
- ${MKDIR} ${EXAMPLESDIR}/tcsh
- ${INSTALL_DATA} ${WRKSRC}/misc/tcsh/* ${EXAMPLESDIR}/tcsh/
+post-install:
# Remove old database
${RM} -f /var/db/pkg/pkgdb.byfile.db
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \