summaryrefslogtreecommitdiff
path: root/palm/gnomepilot/Makefile
diff options
context:
space:
mode:
authorYukihiro Nakai <nakai@FreeBSD.org>1999-12-28 02:26:40 +0000
committerYukihiro Nakai <nakai@FreeBSD.org>1999-12-28 02:26:40 +0000
commit33016534bb0d9b12027a728b0bbf0c05e4ac8f80 (patch)
tree9b4556d10b63256e6ce3a4a18954a8aeb6e3a3f3 /palm/gnomepilot/Makefile
parentAdd more MASTER_SITE. (diff)
New ports GNOME communication tool for palm pilot.
PR: ports/15727 Submitted by: Ade Lovett <ade@lovett.com>
Diffstat (limited to 'palm/gnomepilot/Makefile')
-rw-r--r--palm/gnomepilot/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/palm/gnomepilot/Makefile b/palm/gnomepilot/Makefile
new file mode 100644
index 000000000000..cf8823de59a3
--- /dev/null
+++ b/palm/gnomepilot/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: gnomepilot
+# Version required: 0.1.46
+# Date created: 28th October 1999
+# Whom: Ade Lovett <ade@lovett.com>
+#
+# $FreeBSD$
+
+DISTNAME= gnome-pilot-0.1.46
+PKGNAME= gnomepilot-0.1.46
+CATEGORIES= palm comms gnome
+MASTER_SITES= http://www.gnome.org/gnome-pilot/download/
+
+MAINTAINER= ade@lovett.com
+
+LIB_DEPENDS= pisock.3:${PORTSDIR}/palm/pilot-link \
+ capplet.1:${PORTSDIR}/sysutils/gnomecontrolcenter
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --with-pisock=${LOCALBASE}/pilot
+CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" GLIB_CONFIG="${GLIB_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>