summaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
committerAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
commit54a0b86543e9ffa811825f0afecea56e89aac2a5 (patch)
treef56fb969c6a70f5e63287a4f791d035ab1ef0ddc /news
parentRemove full path in patch (diff)
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in exactly the same way as USE_AUTOTOOLS itself. Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME team -- all GNOME 2.12.x ports use it. Preliminary documentation can be found at: http://people.FreeBSD.org/~ade/autotools.txt which is in the process of being SGMLized before introduction into the Porters Handbook. Light blue touch-paper. Run.
Diffstat (limited to 'news')
-rw-r--r--news/grn/Makefile2
-rw-r--r--news/newscache/Makefile4
-rw-r--r--news/nntpcache/Makefile2
3 files changed, 3 insertions, 5 deletions
diff --git a/news/grn/Makefile b/news/grn/Makefile
index 84c9e464b961..0c2fb14f9da0 100644
--- a/news/grn/Makefile
+++ b/news/grn/Makefile
@@ -20,7 +20,7 @@ USE_BZIP2= yes
USE_PERL5= yes
USE_GNOME= gnomehack gnomelibs gnomeprefix
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
LIBTOOLFILES= configure libmutt/configure
CONFIGURE_ENV= glibpath="${GLIB_CONFIG}" \
diff --git a/news/newscache/Makefile b/news/newscache/Makefile
index 9c10a8781f15..2b97e99184f0 100644
--- a/news/newscache/Makefile
+++ b/news/newscache/Makefile
@@ -17,9 +17,7 @@ COMMENT= NewsCache is a free cache server for USENET News
LIB_DEPENDS= socket[+][+].1:${PORTSDIR}/net/libsocket++
-USE_AUTOMAKE_VER= 19
-USE_AUTOHEADER_VER= 259
-USE_AUTOCONF_VER= 259
+USE_AUTOTOOLS= automake:19 autoheader:259 autoconf:259
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
AUTOMAKE_ARGS= --add-missing
diff --git a/news/nntpcache/Makefile b/news/nntpcache/Makefile
index 813278ac86cb..6093151c59b3 100644
--- a/news/nntpcache/Makefile
+++ b/news/nntpcache/Makefile
@@ -16,7 +16,7 @@ MASTER_SITES= ftp://ftp.cs.tu-berlin.de/pub/net/news/nntpcache/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= News caching/anti-spam/server-merging system
-WANT_AUTOMAKE_VER=15
+USE_AUTOTOOLS= automake:15:env
.if defined(WITH_LDAP) || defined(WITH_LDAP2)
USE_OPENLDAP= yes