summaryrefslogtreecommitdiff
path: root/news/slrn/Makefile
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2012-06-15 08:27:05 +0000
committerJohan van Selst <johans@FreeBSD.org>2012-06-15 08:27:05 +0000
commit4432749711776c4b03fe1976161a85e2cd8ab61a (patch)
tree1519b39ffb12103b7f6ff0978aa7bc4514879182 /news/slrn/Makefile
parent- Fix OPTIONS_DEFINE and OPTIONS_DEFAULT (diff)
- Add conflicts
- Use new style options - Remove unneeded library version numbers - No functional changes
Diffstat (limited to 'news/slrn/Makefile')
-rw-r--r--news/slrn/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/news/slrn/Makefile b/news/slrn/Makefile
index b8a38ece4d55..79d63230c272 100644
--- a/news/slrn/Makefile
+++ b/news/slrn/Makefile
@@ -18,14 +18,15 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION} \
MAINTAINER= johans@FreeBSD.org
COMMENT= SLang-based newsreader
-LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
+LIB_DEPENDS= slang:${PORTSDIR}/devel/libslang2
+
+CONFLICTS_INSTALL= ja-slrn-[0-9]*
USE_GMAKE= yes
USE_ICONV= yes
-OPTIONS= NLS "Native Language Support via gettext utilities" on \
- SSL "Adds support for SSL (Secure Socket Layer)" on \
- DEVIEW "Enable uulib for multiple de-/encoding" off
+OPTIONS_DEFINE= SSL DEVIEW
+OPTIONS_DEFAULT=SSL
.include <bsd.port.options.mk>
@@ -41,17 +42,17 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-ipv6 --disable-inews --with-slrnpull \
--with-libiconv-prefix=${LOCALBASE}
-.if !defined(WITHOUT_SSL)
+.if ${PORT_OPTIONS:MSSL}
USE_OPENSSL= YES
CONFIGURE_ARGS+= --with-ssl
.endif
-.if defined(WITH_DEVIEW)
-LIB_DEPENDS+= uu.3:${PORTSDIR}/converters/uulib
+.if ${PORT_OPTIONS:MDEVIEW}
+LIB_DEPENDS+= uu:${PORTSDIR}/converters/uulib
CONFIGURE_ARGS+= --with-uulib
.endif
-.if defined(NOPORTDOCS)
+.if empty(PORT_OPTIONS:MDOCS)
# Use dummy target rather than rewriting makefile
CONFIGURE_ARGS+= --with-docdir=${WRKSRC}/dummy
.endif