summaryrefslogtreecommitdiff
path: root/news/nntpcache/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-03-30 10:14:36 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-03-30 10:14:36 +0000
commit2002767acb35541647029b8cfc513f97031e4a20 (patch)
tree59731e236647a910bb9f8b00a170046d33800936 /news/nntpcache/Makefile
parentUse autoconf 2.53 for lang/ruby_static-devel and unbreak it. (diff)
Updated with new Option, some cleanups.
>Number: 30849 news/nntpcache fails compiling authinfo_pam.c, add radius & ldap auth mechanisms. The fix is to place a #ifndef __FreeBSD__ .. #endif arround <security/pam_misc.h> in authinfo_pam.c. The attached patch corrects this problem, and adds additional authentication functionality to the nntpcache port (RADIUS, LDAP[v1,v2]). files/patch-src-authinfo_pam.ext removed due to a post-configure target is added to the Makefile that recreates the authinfo_[pam,radius,ldap].ext files. PR: 30849 Submitted by: hetzels@westbend.net
Diffstat (limited to '')
-rw-r--r--news/nntpcache/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/news/nntpcache/Makefile b/news/nntpcache/Makefile
index b636af08735d..9eacbb09878e 100644
--- a/news/nntpcache/Makefile
+++ b/news/nntpcache/Makefile
@@ -16,6 +16,16 @@ MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= automake14:${PORTSDIR}/devel/automake14
+.if defined(WITH_LDAP) && !defined(WITH_LDAP2)
+LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap
+LIB_DEPENDS+= lber.1:${PORTSDIR}/net/openldap
+.endif
+
+.if defined(WITH_LDAP2)
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2
+LIB_DEPENDS+= lber.2:${PORTSDIR}/net/openldap2
+.endif
+
# This may be set interactively at install-time. NNTPCache will
# cache news articles and related data in ${SPOOLDIR}/nntpcache.
SPOOLDIR?= /var/spool
@@ -24,6 +34,20 @@ NO_CDROM= Free for individuals and non-military, non-profit organisations only
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${SPOOLDIR}
+
+AUTHINFO_EXT= authinfo_pam.ext
+.if !defined(WITHOUT_RADIUS)
+CONFIGURE_ARGS+= --with-authinfo-radius
+AUTHINFO_EXT+= authinfo_radius.ext
+.endif
+.if defined(WITH_LDAP) || defined(WITH_LDAP2)
+CONFIGURE_ARGS+= --with-authinfo-ldap
+CPPFLAGS+= -I${PREFIX}/include -I${LOCALBASE}/include
+LDFLAGS+= -L${PREFIX}/lib -L${LOCALBASE}/lib
+AUTHINFO_EXT+= authinfo_ldap.ext
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.endif
+
NNTPSPOOLDIR?= ${SPOOLDIR}/${PORTNAME}
PLIST_SUB+= SPOOLDIR=${NNTPSPOOLDIR}
CPIO= cpio --quiet -pdum -R
@@ -31,6 +55,18 @@ MAN8= nntpcached.8 newshound.8
DOCS= AUTHORS ChangeLog FAQ FAQ.html HACKING HTML \
INSTALL LICENSING NEWS README README.INN VERSION
+.if !defined(BATCH)
+post-fetch:
+ @${ECHO} "To enable LDAP support use either:"
+ @${ECHO} " WITH_LDAP - LDAP v1 support"
+ @${ECHO} " WITH_LDAP2 - LDAP v2 support"
+ @${ECHO}
+ @${ECHO} "To disable radius support use WITHOUT_RADIUS"
+.endif
+
+post-configure:
+ @cd ${WRKSRC}/src && ${GMAKE} ${AUTHINFO_EXT}
+
post-patch:
@${PERL} -pi -e 's,AUTOMAKE=automake,AUTOMAKE=automake14,' \
${WRKSRC}/configure