summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-07-12 19:11:08 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-07-12 19:11:08 +0000
commitf4e8daaa87e4e5ac4f5269c24726b1b5bc026a92 (patch)
treec44290acf48c9b3bbeb42c5efc1dfced2adbb938 /net
parentUpdate ruby-dbi and ruby-dbd_* modules to 0.0.7. (diff)
Add ruby-urb, a Ruby library for handling URIs, which will replace
ruby-uri in the not-too-distant future.
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/ruby-urb/Makefile36
-rw-r--r--net/ruby-urb/distinfo1
-rw-r--r--net/ruby-urb/pkg-comment1
-rw-r--r--net/ruby-urb/pkg-descr5
-rw-r--r--net/ruby-urb/pkg-plist16
6 files changed, 60 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index c46d9a429582..d744f28cc0f1 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -327,6 +327,7 @@
SUBDIR += ruby-pcap
SUBDIR += ruby-snmp
SUBDIR += ruby-soap
+ SUBDIR += ruby-urb
SUBDIR += ruby-uri
SUBDIR += ruby-xmlrpc
SUBDIR += rwhois
diff --git a/net/ruby-urb/Makefile b/net/ruby-urb/Makefile
new file mode 100644
index 000000000000..bc888b795e54
--- /dev/null
+++ b/net/ruby-urb/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: URb
+# Date created: 13 July 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= urb
+PORTVERSION= 0.3
+CATEGORIES= net ruby
+MASTER_SITES= http://arika.org/archive/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+DOCS= ChangeLog README
+
+do-install:
+ ${MKDIR} ${RUBY_SITELIBDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/urb.rb ${RUBY_SITELIBDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/urb/* ${RUBY_SITELIBDIR}/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/test/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/ruby-urb/distinfo b/net/ruby-urb/distinfo
new file mode 100644
index 000000000000..5598a3ca0031
--- /dev/null
+++ b/net/ruby-urb/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/urb-0.3.tar.gz) = 244b384726ad6370ee9f4997d43b7310
diff --git a/net/ruby-urb/pkg-comment b/net/ruby-urb/pkg-comment
new file mode 100644
index 000000000000..67674220f38b
--- /dev/null
+++ b/net/ruby-urb/pkg-comment
@@ -0,0 +1 @@
+A Ruby library for handling URIs
diff --git a/net/ruby-urb/pkg-descr b/net/ruby-urb/pkg-descr
new file mode 100644
index 000000000000..c3ca305d4998
--- /dev/null
+++ b/net/ruby-urb/pkg-descr
@@ -0,0 +1,5 @@
+This is a Ruby library for handling URIs, which will replace ruby-uri
+in the not-too-distant future.
+
+Author: akira yamada <akira@ruby-lang.org>
+WWW: http://www.ruby-lang.org/en/raa-list.rhtml?name=URb
diff --git a/net/ruby-urb/pkg-plist b/net/ruby-urb/pkg-plist
new file mode 100644
index 000000000000..317b4e7458ff
--- /dev/null
+++ b/net/ruby-urb/pkg-plist
@@ -0,0 +1,16 @@
+%%RUBY_SITELIBDIR%%/urb.rb
+%%RUBY_SITELIBDIR%%/urb/common.rb
+%%RUBY_SITELIBDIR%%/urb/ftp.rb
+%%RUBY_SITELIBDIR%%/urb/generic.rb
+%%RUBY_SITELIBDIR%%/urb/http.rb
+%%RUBY_SITELIBDIR%%/urb/https.rb
+%%RUBY_SITELIBDIR%%/urb/ldap.rb
+%%RUBY_SITELIBDIR%%/urb/mailto.rb
+@dirrm %%RUBY_SITELIBDIR%%/urb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/urb/ldap.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/urb/mailto.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/urb/testsuite.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/urb
+%%PORTDOCS%%%%RUBY_DOCDIR%%/urb/ChangeLog
+%%PORTDOCS%%%%RUBY_DOCDIR%%/urb/README
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/urb