summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-05-30 07:19:41 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-05-30 07:19:41 +0000
commitcd62882342c743ed1371a3fbc1618195ddf2221c (patch)
tree0a1245f88ae203586be5312d2872f8e82b742c6d /net
parentBROKEN for perl < 500600: Broken pkg-plist (diff)
- net/GeoIP uses its own libtool even if we define USE_LIBTOOL*
- add missing @exec and remove old SIZE in net/GeoIP - update for libGeoIP.4 in LIB_DEPENDS and bump PORTREVISION - utilize PORTDOCS in www/mod_geoip Noticed by: kris
Diffstat (limited to 'net')
-rw-r--r--net/GeoIP/Makefile3
-rw-r--r--net/GeoIP/distinfo1
-rw-r--r--net/GeoIP/pkg-plist1
-rw-r--r--net/p5-Geo-IP/Makefile4
-rw-r--r--net/py-GeoIP/Makefile3
-rw-r--r--net/ruby-net-geoip/Makefile6
-rw-r--r--net/verlihub/Makefile3
7 files changed, 11 insertions, 10 deletions
diff --git a/net/GeoIP/Makefile b/net/GeoIP/Makefile
index 7660e2e44a65..c7758e529282 100644
--- a/net/GeoIP/Makefile
+++ b/net/GeoIP/Makefile
@@ -13,8 +13,7 @@ MASTER_SITES= http://www.maxmind.com/download/geoip/api/c/
MAINTAINER= seanc@FreeBSD.org
COMMENT= Find the country that any IP address or hostname originates from
-USE_LIBTOOL_VER=13
-CONFIGURE_ARGS= --with-gnu-ld=yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
MAN1= geoiplookup.1 geoipupdate.1
diff --git a/net/GeoIP/distinfo b/net/GeoIP/distinfo
index e14139183763..ce2a4adb3755 100644
--- a/net/GeoIP/distinfo
+++ b/net/GeoIP/distinfo
@@ -1,3 +1,2 @@
MD5 (GeoIP-1.3.1.tar.gz) = cbfb7be70e2b02140677008d6e902dac
SIZE (GeoIP-1.3.1.tar.gz) = 526429
-SIZE (GeoIP-1.2.2.tar.gz) = 512557
diff --git a/net/GeoIP/pkg-plist b/net/GeoIP/pkg-plist
index 2b15652d4acd..7721e30ee25c 100644
--- a/net/GeoIP/pkg-plist
+++ b/net/GeoIP/pkg-plist
@@ -4,6 +4,7 @@ bin/geoiplookup
bin/geoipupdate
@unexec if cmp -s %D/etc/GeoIP.conf %D/etc/GeoIP.conf.default; then rm -f %D/etc/GeoIP.conf; fi
etc/GeoIP.conf.default
+@exec [ -f %B/GeoIP.conf ] || cp %B/%f %B/GeoIP.conf
include/GeoIP.h
include/GeoIPBitReader.h
include/GeoIPCity.h
diff --git a/net/p5-Geo-IP/Makefile b/net/p5-Geo-IP/Makefile
index 527e4201ed22..c10caf98e4de 100644
--- a/net/p5-Geo-IP/Makefile
+++ b/net/p5-Geo-IP/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Geo-IP
PORTVERSION= 1.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
http://www.maxmind.com/download/geoip/api/perl/
@@ -17,7 +17,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= seanc@FreeBSD.org
COMMENT= Gets country name by IP or hostname
-LIB_DEPENDS= GeoIP.3:${PORTSDIR}/net/GeoIP
+LIB_DEPENDS= GeoIP.4:${PORTSDIR}/net/GeoIP
PERL_CONFIGURE= yes
CONFIGURE_ARGS= LIBS='-L${LOCALBASE}/lib' INC='-I${LOCALBASE}/include'
diff --git a/net/py-GeoIP/Makefile b/net/py-GeoIP/Makefile
index a8ebd9df309e..31f343c7c9c1 100644
--- a/net/py-GeoIP/Makefile
+++ b/net/py-GeoIP/Makefile
@@ -7,6 +7,7 @@
PORTNAME= GeoIP
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= http://www.maxmind.com/download/geoip/api/python/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,7 +16,7 @@ DISTNAME= ${PORTNAME}-Python-${PORTVERSION}
MAINTAINER= sw@gegenunendlich.de
COMMENT= Mapping of IP addresses/hostnames to country names in Python
-LIB_DEPENDS= GeoIP:${PORTSDIR}/net/GeoIP
+LIB_DEPENDS= GeoIP.4:${PORTSDIR}/net/GeoIP
USE_PYTHON= yes
USE_PYDISTUTILS=yes
diff --git a/net/ruby-net-geoip/Makefile b/net/ruby-net-geoip/Makefile
index 24017959c9af..c50344eb847d 100644
--- a/net/ruby-net-geoip/Makefile
+++ b/net/ruby-net-geoip/Makefile
@@ -7,7 +7,7 @@
PORTNAME= net-geoip
PORTVERSION= 0.06
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ruby
MASTER_SITES= http://www.rubynet.org/modules/net/geoip/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -16,9 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= seanc@FreeBSD.org
COMMENT= A Ruby extension that wraps around libGeoIP
-LIB_DEPENDS= GeoIP.3:${PORTSDIR}/net/GeoIP
+LIB_DEPENDS= GeoIP.4:${PORTSDIR}/net/GeoIP
-USE_BZIP2= yes
+USE_BZIP2= yes
USE_ICONV= yes
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/net/verlihub/Makefile b/net/verlihub/Makefile
index c810b3d0b6ea..a55285b2f158 100644
--- a/net/verlihub/Makefile
+++ b/net/verlihub/Makefile
@@ -7,6 +7,7 @@
PORTNAME= verlihub
PORTVERSION= 0.9.7r5
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= verlihub
@@ -15,7 +16,7 @@ DISTNAME= verlihub-0.9.7-RC5
MAINTAINER= hurbold@yahoo.com
COMMENT= Verlihub Linux/Unix Direct Connect Hub Software
-LIB_DEPENDS= GeoIP.3:${PORTSDIR}/net/GeoIP \
+LIB_DEPENDS= GeoIP.4:${PORTSDIR}/net/GeoIP \
pcre.0:${PORTSDIR}/devel/pcre
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2