summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-03-19 19:14:32 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-03-19 19:14:32 +0000
commit7d63224d50526ea12a9066a1c831cb9509bf5187 (patch)
tree21151b75e6f8e39d5ee78b2bf2e1e28ba8775111 /net
parent- fix depends for INN (diff)
Use IGNORE macros to bug user that he/she has to manually download distfile
instead of failing rule. This will prevent bento from trying to build the port. Submitted by: bento
Diffstat (limited to 'net')
-rw-r--r--net/socks5/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/net/socks5/Makefile b/net/socks5/Makefile
index b1a2d3095ce3..a4206f69391c 100644
--- a/net/socks5/Makefile
+++ b/net/socks5/Makefile
@@ -36,15 +36,8 @@ MAN1= runsocks.1 socks5.1 stopsocks.1 socks5_clients.1
MAN5= libsocks5.conf.5 socks5.conf.5
CONFIGURE_ENV= LIBS=-lcrypt
-do-fetch:
- @if [ ! -f ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ]; then \
- ${ECHO} ""; \
- ${ECHO} "NEC requires that you grab the dist files from their"; \
- ${ECHO} "web site at http://www.socks.nec.com. Please make sure"; \
- ${ECHO} "you have ${DISTNAME}${EXTRACT_SUFX} in ${DISTDIR}"; \
- ${ECHO} "and run make again."; \
- ${ECHO} ""; \
- exit 1;\
- fi
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE="NEC requires that you grab the dist files from their web site at http://www.socks.nec.com. Please make sure you have ${DISTNAME}${EXTRACT_SUFX} in ${DISTDIR} and run make again."
+.endif
.include <bsd.port.mk>