summaryrefslogtreecommitdiff
path: root/net/zillion
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-11-09 20:08:01 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-11-09 20:08:01 +0000
commitccefc7f2e037a58c6dad41ffbc7d00a02225a05c (patch)
tree0f86cf27a5e3275460d6c9a6bd620d8b61056e6b /net/zillion
parentRemoteDesk is a graphical interface to rdesktop (diff)
The Zillion Project is a distributed computing project reminiscent of the good
old Zilla.app of NeXTstep days. It is based on GNUstep, the most promising OPENSTEP replacement as of today. Jobs can be created from simple template projects and can be submitted with a single command to the Zillion Server which in turn will distribute the job amongst the registered clients. No other network resources than the distributed objects (DO) port of the server machine has to be available. The key features are as follows: * Rapid turn around cycles for job submission * Dynamic addition/removal of client nodes * Full OO-design * No need for shared network resources * Real-time capabilities * Lean and clean * Open and free WWW: http://zillion.sourceforge.net/
Diffstat (limited to 'net/zillion')
-rw-r--r--net/zillion/Makefile28
-rw-r--r--net/zillion/distinfo3
-rw-r--r--net/zillion/pkg-descr16
-rw-r--r--net/zillion/pkg-plist9
4 files changed, 56 insertions, 0 deletions
diff --git a/net/zillion/Makefile b/net/zillion/Makefile
new file mode 100644
index 000000000000..7dad948c36e9
--- /dev/null
+++ b/net/zillion/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: zillion
+# Date created: 09 Nov 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= zillion
+PORTVERSION= 0.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-0_1
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Distributed computing project
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE=
+ALL_TARGET=
+
+.include <bsd.port.mk>
diff --git a/net/zillion/distinfo b/net/zillion/distinfo
new file mode 100644
index 000000000000..442b43a325e2
--- /dev/null
+++ b/net/zillion/distinfo
@@ -0,0 +1,3 @@
+MD5 (zillion-0_1.tar.gz) = b8cfb038ec9261893c33805345a04c45
+SHA256 (zillion-0_1.tar.gz) = 553ed82d710ab55c9ecf0979ae85710496cce9b62cf618b31f3bed0186fd3579
+SIZE (zillion-0_1.tar.gz) = 14418
diff --git a/net/zillion/pkg-descr b/net/zillion/pkg-descr
new file mode 100644
index 000000000000..c3a0d6116b8c
--- /dev/null
+++ b/net/zillion/pkg-descr
@@ -0,0 +1,16 @@
+The Zillion Project is a distributed computing project reminiscent of the good
+old Zilla.app of NeXTstep days. It is based on GNUstep, the most promising
+OPENSTEP replacement as of today. Jobs can be created from simple template
+projects and can be submitted with a single command to the Zillion Server
+which in turn will distribute the job amongst the registered clients. No other
+network resources than the distributed objects (DO) port of the server machine
+has to be available. The key features are as follows:
+ * Rapid turn around cycles for job submission
+ * Dynamic addition/removal of client nodes
+ * Full OO-design
+ * No need for shared network resources
+ * Real-time capabilities
+ * Lean and clean
+ * Open and free
+
+WWW: http://zillion.sourceforge.net/
diff --git a/net/zillion/pkg-plist b/net/zillion/pkg-plist
new file mode 100644
index 000000000000..7b796c4f981c
--- /dev/null
+++ b/net/zillion/pkg-plist
@@ -0,0 +1,9 @@
+Local/Library/Bundles/simpleZillionJob.bundle/Resources/Info-gnustep.plist
+Local/Library/Bundles/simpleZillionJob.bundle/simpleZillionJob
+Local/Library/Bundles/simpleZillionJob.bundle/stamp.make
+Local/Tools/zillion
+Local/Tools/zillionClient
+Local/Tools/zillionLoader
+@dirrm Local/Library/Bundles/simpleZillionJob.bundle/Resources
+@dirrm Local/Library/Bundles/simpleZillionJob.bundle
+@dirrm Local/Library/Bundles