summaryrefslogtreecommitdiff
path: root/net/p5-Net-DNS/Makefile
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2002-06-05 09:51:38 +0000
committerDoug Barton <dougb@FreeBSD.org>2002-06-05 09:51:38 +0000
commitedb263b95e9cc7c97a4736a3bbaf1c55db768186 (patch)
tree30ed189d6ea2570e9344eb7f1981324f8aa208ad /net/p5-Net-DNS/Makefile
parentFix Japanese display problem. (diff)
Update to the latest, 0.21. This version contains many changes,
please see the Changes file for details. Some of the new features include TSIG support (experimental), a name server module, fixes for bind() problems in 5.005.03, and more. The good news is that our friends in perldom have now seen the light and fixed the later versions of this module so that it does not (any longer) require perl 5.6.0 or higher. I've tested quite a lot of the functions on both a RELENG_4 with stock perl 5.005.03, and a 5-Current system with stock 5.6.1, and didn't have any problems. I also added a few files to the PORTDOCS option.
Diffstat (limited to 'net/p5-Net-DNS/Makefile')
-rw-r--r--net/p5-Net-DNS/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/net/p5-Net-DNS/Makefile b/net/p5-Net-DNS/Makefile
index fbd8ad07a015..a9a51c20d5fa 100644
--- a/net/p5-Net-DNS/Makefile
+++ b/net/p5-Net-DNS/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Net-DNS
-PORTVERSION= 0.14
+PORTVERSION= 0.21
CATEGORIES= net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Net
@@ -14,6 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= DougB@FreeBSD.org
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Digest/HMAC_MD5.pm:${PORTSDIR}/security/p5-Digest-HMAC \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
@@ -31,4 +34,12 @@ MAN3= Net::DNS.3 Net::DNS::Header.3 Net::DNS::Packet.3 \
Net::DNS::RR::NIMLOC.3 Net::DNS::RR::NSAP.3 \
Net::DNS::RR::NULL.3 Net::DNS::RR::PX.3 Net::DNS::Update.3
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/p5-Net-DNS
+.for file in Changes README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/p5-Net-DNS
+.endfor
+.endif
+
.include <bsd.port.mk>