summaryrefslogtreecommitdiff
path: root/net/p0f
diff options
context:
space:
mode:
authorGarrett Wollman <wollman@FreeBSD.org>2004-02-23 04:42:13 +0000
committerGarrett Wollman <wollman@FreeBSD.org>2004-02-23 04:42:13 +0000
commit60aab665670e50cb18bba45ee25f2ed091759741 (patch)
tree924c1af9c149083e0626ceb279b67ad6ca69e630 /net/p0f
parentBROKEN on !i386: Does not compile (diff)
Say hello to the new "net-mgmt" category. There are probably more
ports that belong here than the ones I have identified and moved in this, first, pass. Approved in principle by: marcus
Diffstat (limited to 'net/p0f')
-rw-r--r--net/p0f/distinfo3
-rw-r--r--net/p0f/files/patch-FreeBSD16
-rw-r--r--net/p0f/files/patch-mtu.h14
-rw-r--r--net/p0f/files/patch-p0f.c43
-rw-r--r--net/p0f/files/patch-test_p0fq.c12
-rw-r--r--net/p0f/pkg-descr23
6 files changed, 0 insertions, 111 deletions
diff --git a/net/p0f/distinfo b/net/p0f/distinfo
deleted file mode 100644
index f0d1ba7149c7..000000000000
--- a/net/p0f/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-$FreeBSD$
-MD5 (p0f-2.0.3.tgz) = 583688a4c5718eec0bb34102b3ac457b
-SIZE (p0f-2.0.3.tgz) = 119407
diff --git a/net/p0f/files/patch-FreeBSD b/net/p0f/files/patch-FreeBSD
deleted file mode 100644
index 0de9b2359258..000000000000
--- a/net/p0f/files/patch-FreeBSD
+++ /dev/null
@@ -1,16 +0,0 @@
-$FreeBSD$
-
---- mk/FreeBSD.orig Sat Aug 30 15:41:17 2003
-+++ mk/FreeBSD Mon Sep 8 03:58:17 2003
-@@ -7,10 +7,9 @@
- # (C) Copyright 2000-2003 by Michal Zalewski <lcamtuf@coredump.cx>
- #
-
--CC = gcc
-+CC? = gcc
- LIBS = -lpcap -I/usr/include/pcap -I/usr/local/include/pcap
- STRIP = strip
--CFLAGS = -O3 -Wall -fomit-frame-pointer -funroll-loops
- FILE = p0f
-
- all: $(FILE) strip
diff --git a/net/p0f/files/patch-mtu.h b/net/p0f/files/patch-mtu.h
deleted file mode 100644
index 116c1ae95371..000000000000
--- a/net/p0f/files/patch-mtu.h
+++ /dev/null
@@ -1,14 +0,0 @@
-$FreeBSD$
-Add loopback support for FreeBSD.
-author: Radim Kolar
-
---- mtu.h.orig Fri Oct 10 20:56:39 2003
-+++ mtu.h Tue Feb 17 21:10:49 2004
-@@ -58,6 +58,7 @@
- { 4352, "FDDI" },
- { 4500, "token ring (2)" },
- { 9180, "FORE ATM" },
-+ { 16384, "loopback" },
- { 16436, "sometimes loopback" },
- { 18000, "token ring x4" },
- };
diff --git a/net/p0f/files/patch-p0f.c b/net/p0f/files/patch-p0f.c
deleted file mode 100644
index 449f830730e7..000000000000
--- a/net/p0f/files/patch-p0f.c
+++ /dev/null
@@ -1,43 +0,0 @@
-$FreeBSD$
-Add loopback support for FreeBSD.
-author: Radim Kolar
-
---- p0f.c.orig Tue Feb 17 21:11:51 2004
-+++ p0f.c Tue Feb 17 21:10:48 2004
-@@ -161,7 +161,8 @@
-
- switch(type) {
-
-- case DLT_NULL:
-+ case DLT_NULL: header_len=4; break;
-+
- case DLT_SLIP:
- case DLT_RAW: break;
-
-@@ -1199,11 +1200,15 @@
- /* Whoops, IP header ends past end_ptr */
- if ((_u8*)(iph + 1) > end_ptr) return;
-
-- if ( ((iph->ihl & 0x40) != 0x40) || iph->proto != IPPROTO_TCP) {
-- debug("[!] WARNING: Non-IP packet received. Bad header_len!\n");
-+ if ( iph->proto != IPPROTO_TCP) {
-+ debug("[!] WARNING: Non-IP packet received.\n");
- return;
- }
-
-+ if ( ((iph->ihl & 0x40) != 0x40) ) {
-+ debug("[!] WARNING: Bad header_len!\n");
-+ return;
-+ }
- /* If the declared length is shorter than the snapshot (etherleak
- or such), truncate this bad boy. */
-
-@@ -1590,7 +1595,7 @@
- if (!use_iface) use_iface=pcap_lookupdev(errbuf);
- #endif /* ^WIN32 */
-
-- if (!use_iface) use_iface = "lo";
-+ if (!use_iface) use_iface = "lo0";
-
- /* We do not rely on pcap timeouts - they suck really bad. Of
- course, the documentation sucks, and if you use the timeout
diff --git a/net/p0f/files/patch-test_p0fq.c b/net/p0f/files/patch-test_p0fq.c
deleted file mode 100644
index eb1d0372afb1..000000000000
--- a/net/p0f/files/patch-test_p0fq.c
+++ /dev/null
@@ -1,12 +0,0 @@
-$FreeBSD$
-
---- test/p0fq.c.orig Fri Oct 10 14:51:08 2003
-+++ test/p0fq.c Wed Dec 17 20:10:31 2003
-@@ -14,6 +14,7 @@
-
- */
-
-+#include <sys/types.h>
- #include <sys/socket.h>
- #include <stdio.h>
- #include <stdlib.h>
diff --git a/net/p0f/pkg-descr b/net/p0f/pkg-descr
deleted file mode 100644
index def189dd1264..000000000000
--- a/net/p0f/pkg-descr
+++ /dev/null
@@ -1,23 +0,0 @@
-from the README:
-
-Passive OS fingerprinting is based on information coming from a remote host
-when it establishes a connection to our system. Captured packets contain
-enough information to identify the operating system. In contrast to active
-scanners such as nmap and QueSO, p0f does not send anything to the host being
-identified.
-
-For more information, read Spitzner's text at:
-http://www.enteract.com/~lspitz/finger.html .
-
-from the maintainer:
-
-Use of this program requires read access to the packet filtering
-device, typically /dev/bpf0. Granting such access allows the users
-who have it to put your Ethernet device into promiscuous mode and
-sniff your network. See
-http://www.infoworld.com/articles/op/xml/00/05/29/000529opswatch.xml
-if you do not understand how this can be harmful. Running p0f with
-no options will cause it to analyse packets intended for other
-hosts.
-
-WWW: http://www.stearns.org/p0f/