summaryrefslogtreecommitdiff
path: root/net/lmule
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-06-11 22:23:53 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-06-11 22:23:53 +0000
commit90484f872fa5466e4bf333ecdaafed07fde7c260 (patch)
tree5dee72693321dfbf2a6a24603bef7e50c0c4c58f /net/lmule
parentFix build in 5.x branch: machine/soundcard.h -> sys/soundcard.h (diff)
Improve detection on whether wxgtk was built against gtk12 or gtk20
Diffstat (limited to 'net/lmule')
-rw-r--r--net/lmule/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net/lmule/Makefile b/net/lmule/Makefile
index de7e73d74fda..915f0354e386 100644
--- a/net/lmule/Makefile
+++ b/net/lmule/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS= --without-included-gettext \
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-WX_CONFIG?= "${X11BASE}/bin/wx-config"
+WX_CONFIG?= ${X11BASE}/bin/wx-config
post-patch:
# it works for FreeBSD as well
@@ -53,12 +53,12 @@ post-install:
.if exists(${WX_CONFIG})
# detect if wxgtk was linked against gtk1 or gtk2
-DECISION_GTK_1_OR_2!= ${WX_CONFIG} --cppflags
+DECISION_GTK_1_OR_2!= ${WX_CONFIG} --static --libs
.else
DECISION_GTK_1_OR_2= ""
.endif
-.if (${DECISION_GTK_1_OR_2:Mgtk2} != "")
+.if ${DECISION_GTK_1_OR_2:M*glib-2.0} != ""
USE_GNOME+= gtk20
.else
USE_GNOME+= gtk12